Technical question: is my Creative Labs mp3 player dead?

Three and a bit years ago, I was given a used MuVo2 FM 5 GB mp3 player. I’ve been using it happily ever since, nearly on a daily basis, both to play music and to listen to the radio at work (one earbud is okay with TPTB). Last Monday morning when I got off work, it was working fine. I brought it home and placed the battery on charge.

On Wednesday evening, I went into work, and tried to turn it on. Then came the first symptom of a problem that I noticed. The unit turned on long enough to display first the Creative Labs logo, then to switch to the name of the product (MuVo[sup]2[/sup] FM). Usually, after that, the display tells me that it is loading the music files. Then it goes to the last music file I had been listening to, and will play it if I hit the power/play button (or I can shift to another directory, or to FM).

Instead, it locked up at the product name screen. I tried cycling the power switch, and it was unresponsive. Cycling the battery out and in gave me the same symptom as when I first turned it on. When I got home from work, I plugged the charger back in, and found that the symptoms are not changing. I connected the mini port to a USB input on my computer, and it does not get acknowledged as being in place as an installed device.

I’ve gone ahead and blown eight bucks on having Amazon send me a new battery. I have known of electronic devices that will not function with a dead (as in “not chargeable”) battery in place, even if the charger is plugged into it, although it’s been quite some time since I’ve actually encountered one.

So, while I wait for the new battery to arrive, does anyone know if replacing it will do any good? The Creative Labs phone number in Milpitas, CA has not been answering. Thanks in advance for any assistance. :slight_smile:

I don’t know, and I wish you the best.

I have 2 creative mp3 players myself - one is a 128mb muvo which I got for re-signing up to, and it’s still going strong after many many years - it takes a AAA battery, I use rechargeables, and it doesn’t have a screen, just a blinking light indicator.

The other is a Zen Micro, with a 6 gig hard drive, and it’s already been sent in for servicing once under the extended warranty. (Which was an almighty hassle, since Creative kept Futureshop from handling it at their own warranty desk, so I had to pay to send it in to them. :mad:)

Anyway, the Zen Micro’s been ticking over pretty well. I stopped carrying it around and always left it plugged into the dock, so it didn’t matter that the battery wasn’t up to much.

A month or two ago, I plugged it into the desktop to clear out old playlists and load on some new songs - which I don’t have to do very often with 6 gigs of storage - and found out that it wouldn’t start in MTP mode, no matter what I tried. So, I can still play those songs, but not any others.

Since when, I’ve got a new speakerdock that will connect to an ipod or iphone - and realized that the iphone case I’ve been using for months makes it nearly impossible to dock with any of these speakers. Oh well.

Thanks for letting me ramble. Hope that somebody else comes along soon with a better answer.

Is there a factory reset button anywhere?

Here is a simple reset I found for muvo2. Don’t know if it works but is worth trying.

Thanks for that link, aceplace57. I tried the reset procedure on it, but to no effect. Looks like I’m going to have to wait until the new battery arrives, and see if it restores the device.

Unless anyone else knows something? If I can know for certain that it’s not going to fix the problem, I’ll just nip round to Target and buy another mp3 player. It’s certainly not worth going to Just Answers dot com and paying them $21 to have them tell me I’m screwed.