Television Without Pity takes forever to load a page?

I often like to read the episode recaps at Television Without Pity, but I have noticed that in the last few months whenever I access any page on that site, it freezes up my browser completely for 30-60 seconds. While the page is loading, I can’t access any other Firefox windows. Anyone else having that problem?

Yup. Totally sucks. They don’t need to have pages at all on their recaps, do they? What a PITA reading about ONE friggen episode, but hitting “next” 30 times. And each one takes a month to load.

Well, the reason they have pages is because the site is supported by ad revenue and more pages gives them more opportunities to show ads. But I don’t understand what is in those pages that makes the browser freeze up for so long.

Same complaints.

What shows do you all follow on TWoP?? The recaps vary greatly depending on the author. The only one that I find worth the trouble is Homeland.

Yeah, well pagination is a blight upon the internet and I don’t use websites that page more than once an article so instead of getting to show me 2 or 3 ads, they get to show me none.

While I do not visit Television Without Pity, there’s another website that does the same thing. My solution was to add a custom filter preference in Adblock Plus, blocking the url of the script that was causing the problem.

I don’t read the recaps but I’m a forum fan. Dramas (The Mentalist, Elementary), Game Shows (Jeopardy!) and Project Runway. I used to be into How-To Reality when there were decent shows on HGTV. And yes, it takes for fucking ever for a TWoP page to load.

I consider it a reasonable concession to access content I enjoy. You don’t. Fair enough. But why do the pages take so long to load?

I just went and looked at a Glee recap and it was fine. I paged through it with no issue. However, I use AdBlock.

I turned off AdBlock and immediately had the problem described in the OP. Slow as heck and actually froze for a moment on each page load.

It looks like the main culprit is the square ad on the right between Facebook and the TWOP Videos box. The banner across the top of the page seemed ok.

If you want to not use an ad blocker on the whole site to support it, and just block that one ad, try to get your browser to block the Javascript function “writeAdFrame_300x250()”

Another option:
I will always open the next page in another tab before I start reading. Then it has a few minutes to load before I get to it. Then I’ll close the current tab, and repeat the process. There’s a little extra scrolling, but certainly gets around the problem.

How would I do that in Firefox?

I can’t figure it out, sorry.

If I want to read the last several pages in a particular forum on TWoP, I’ll go to the last page, then click on the link for the previous page, and keep clicking on the previous page until I get to the page I want I want to start reading. (If the last page is 100, Ill click on 100, then page 99, then 98 etc.). All the time I have another tab open on another web site to read while the pages load.

Then to read TWoP I’ll simply press the back button, so the pages load more quickly while I try to read the pages in quick sequence. TWoP is the only web site that I have to do this on.

You can also try turning off Flash. For Firefox, click on the “Firefox” drop-down menu and choose “Add ons.” That will open in a new tab. Scroll down to find Shockwave Flash, click on the “disable” button.

Turning off Flash speeds up a lot of pages.

Is 19 pages reasonable?

Sure, if it’s a long piece. Some of the stuff I read is as short as five pages; some are over 20. It doesn’t bother me. It doesn’t cost me anything to click “next” – provided, of course, that it doesn’t take forever to load a page. Again, this is how they’re paying for content that they’re giving me for free. It makes no sense to take exception to it.

The problem is that while that other page is loading, Firefox freezes up entirely.

Wow, that worked like a charm! Only problem now is that Facebook and Hotmail no longer work. And the “Plus quote” button on SDMB doesn’t work properly either.

I haven’t used Firefox in a long time, so I can’t be very specific but if you get the FlashBlock Add-On, if you don’t already have it, there should be an option to either whitelist the dope, facebook and hotmail or blacklist TWOP.

Loads fine for me under Opera. The two main things I have blocked on it are (usually not a major problem) and something called Don’t know what that is but I suspect that’s the culprit.