Time for another Windows oddity question!

I’m accessing my office PC via RDC. I don’t know what version of Windows I’m using, as there doesn’t appear to be any ‘About this [del]Mac[/del] PC’ option anywhere.

I’m using a secure FTP site to upload a file to another company. I hit Browse to bring up a window so that I can choose the file. Normally the window is smaller than the browser window, which is smaller than the desktop, and it opens to the last folder I used for an upload. This time it opened up to several icons. I think it’s what you get if you choose C: from the left side of the pop-up, but I never use that so I’m not sure. Anyway, I click on the correct dive from the right side of the window. This opened the correct drive. BUT! The window expanded to cover my entire desktop. Usually there is a box with a minus sign in the upper-right corner, next to the box with the X (close window) to minimise the window. This time there wasn’t one. I tried several times to grab the corner an make the window smaller, and to grab the bottom of the window to at least reduce the size in that dimension. Neither worked.

So how do I make the window that pops up when I want to choose a file for uploading smaller? :confused:

There are keyboard shortcuts that can help in situations like that.


Unfortunately, some keyboard shortcuts don’t work on a Mac over RDC. For example, right-click on a Mac is control-click. That doesn’t work when I’m on the PC via RDC, and I have to use the mouse.

Are there scroll bars on the remote desktop window? Your desktop window might be smaller than the desktop you’re viewing and so you’d need to scroll to view the upper-right corner to get to the control bar of the browse window.

It fits the window exactly. I can see the Close button in the upper-right corner, and I can ‘grab’ the lower-right corner (cursor changes to diagonal opposing arrows).

You could use the Accessibility options to pop up an on-screen keyboard. that should give you whatever keystrokes you need.

“Windows Version” is found in right-click (My) Computer - Properties

You should be able to resize the file-picker panel unless it’s in full screen mode (i.e. the middle of the 3 top right boxes is showing as 2 overlapped squares, not one big square - if so click on it to get the single square) or unless whoever programmed the upload program set their own window-resize options for that part.

So which program are you using, exactly? Not sure what RDC has to do with FTP, and what kind of “Browse” window you’re seeing. Can you put a screenshot up on imgur.com?

As for keyboard hotkeys, RDC should let you configure all the hotkeys. In regular Windows, if you push alt-space and then S (for size), it’ll let you use the arrow keys to resize a window even if you can’t find the draggy corners. Alt might be remapped to something else through RDC, but I’m sure it’s there if you look through the documentation. Maybe Option?

However, some windows are locked to a certain size and can’t be easily resized. There are workarounds, but it depends on the specifics… if you can provide more detail, it’d help

Couldn’t find 'My Computer, but I clicked Help on My Documents file and found out I’m using Windows 7 Professional. Then I saw that the Start menu has ‘Computer’ (not ‘My Computer’). :stuck_out_tongue:

The thing about the window size buttons is that there aren’t three like there should be. Only the Close button.

I’m telecommuting today, so I’m on my MacBook Pro. I connect to my desktop computer, 115 miles away, using RDC. The desktop is running Windows 7 Professional.

When I log into the STM page in IE, I can choose a file to upload. I click on the Browse button. Normally, I get a window about 1/5 the size of my desktop (maybe smaller), and it opens to the last folder I used for uploading anything. (There are three different sites, so three different possibilities.) This morning it opened as if I had chosen C: from the Navigation pane. When I clicked on the correct drive, the ‘choose file’ window opened to fullscreen with no option to make it smaller (i.e., only the button in the upper-right corner). I’m sure I didn’t accidentally click anything. I’d post a pic, but I’d rather not put my employer’s name in a public place.

The computer’s been weird for a week. First there was a Windows Security pop-up asking me to log in ever 10 seconds when I’m in Outlook (I wasn’t the only one affected, and the IT guy reset the server), then if I try to find an email in Outlook it looks forever and doesn’t find it so I ‘X’ out of the Find and just try to find it in the folder, and now there’s this weird window size thing in IE.

STM page?

Are you seeing some variant of this guy? You should be able to resize that with the corners or with the alt-space and then S shortcut I posted earlier. You could also try alt-space then R to just restore it to its previous size.

STM page is what they call their FTP site. (I think it means Secure Transport Management, but I’m not sure.)

Yes, that’s the window. But instead of being the size in your link, it covers the whole desktop. I found the alt key on the Mac (I never use it, so I had to find it) and attempted to use it to resize the window. A menu opened up, but Size was greyed out and could not be used.


Try the other hotkey first. Alt-space then R (for restore). Maybe it’ll let you resize it after that. You (or the application) probably just accidentally maximized it. A restore to regular windowed size should enable resizing functionality again.

Edit: If you don’t want to mess with keyboard hotkeys, just double-click the window title (of the browse window, not IE) or single click the upper left corner of the window to bring up the same menu that alt-space does.

I’m betting what happened is you just accidentally double-clicked the window title to maximize the thing.

I don’t want to mess with keyboard hotkeys. I can never remember what they are.

  • Several seconds later… *

OK, I double-clicked ‘Choose file to upload’ and it went back to its regular size. Thanks! (I wish Microsoft didn’t go out of their way to make things un-obvious and un-intuitive.)

It’s not your fault! The “browse” window has seen numerous iterations from Windows 95 to Windows 8, and they’re all kept in there for backward compatibility. So you see different versions of it depending on your Windows version, the specific app in question, and who knows what else. It’s a terrible user experience.

And ya think the double-click thing is bad, just wait till your company moves over to Windows 8 and you have to learn the triple-side-drag, up-down-swipe-click, and the double-middle-finger salute. Now you know how this fellow feels.

Johnny, will you record a video of you singing “Windows Oddity” next time you fly?