Transfering files through a Network HUB

I have two computers which are networked via a hub. One day, I decide to transfer my MP3 directory from one to another. It took a few hours, but it worked. I decide to format the first computer. When everything is networked and set up again, I try to transfer my MP3s back to the first computer. Unfortunatly, It will only get through a song or two before it displays an error message. This has happened 3 times.

Why is this happening? Computer 1 (without the MP3s) is running XP, comp 2 is running 98. It was set up the same way before, when I transfered the other way around.

Also, can I connect the two computers directly (one cord connecting through each’s port) and not through a HUB? Would it transfer faster? How would I go about doing that? (I tried but it didn’t work.)


If this should be in Cafe Society, sorry.

First things first. What was the error message it gave you when it stopped working?

Regarding plugging a cord directly from one computer to the other (i.e. bypassing the hub). Yes, it’s possible but you need to be using a crossover cable. In a network cable you’ll notice that there are actually a number of small wires aligned in a particular order. This is done so that the input on one end get’s received at the correct point on the other end. In a crossover cable the data send and receive wires are simply transposed so that on one end they are set normally and at the other end they’re reversed. Any local computer store should be able to create such a cable for you.

As far as transfer speed is concerned there really isn’t any difference between going through a hub and transferring directly. It’ll be about the same performance wise.


Header: Error Copying File or Folder

Cannot copy (file name): The specified network name is no longer available.

try sending your mp3s and exclude the file that errors. THe windows 98 machine might have bad sectors.

Whups, didn’t notice the network error message. Try sending from the XP machine to the 98 machine. One of the wires in your cat 5 cable could be bad, but I doubt it.

A direct connection may be a bit faster. A hub is half duplex, so only one computer can be “talking” at a time without causing collisions. Like a switch, a crossover cable between NICs will allow a full duplex connection between the two computers.

That being said, from what’s been said elswhere in the thread I don’t think this is the problem.

Your problem is most likely related to the way your XP network access permissions are set, and if you did a format re-install on one of the PCs these will need to be re-configured. XP is very picky security-wise and does not like sharing files with 95/98/ME machines unless these permissions are set correctly.

IIRC Windows XP requires a special step be taken to allow networking in a Peer-to-Peer fashion. I can check when I get home but I believe the XP machine will generate a disk (floppy) for you that you need to execute on any non-XP machines hooked to the network.

I doubt that both of these statements are correct. I suspect that when you attempted to copy the files, you get the little dialog box that shows files flying between folders, and then you get the error message pretty quickly. I sincerely doubt, based on the error message, that ANY MP3s were actually transferred. Can you confirm that at least one did transfer?

The error message indicates that you are not quite networked again.

You say you decided the format the first computer. Do you mean that you formatted the harddrive, then reinstalled the operating system?

How are you “finding” the other computer through the network? Are you using a mapped network drive, or using Network Neighborhood, or something else?

Until we can nail down the problem (which appears to be in accessing the other computer through a “network name”), I will hestitate to try and give more explicit suggestions. However, you may try copying the files in the other direction. That is, if you have been on the Win98 machine and copying to a network share on the XP machine, try sitting on the XP machine and accessing the Win98 share.

Oh, and while the cross-over cable will be quicker, the difference isn’t significant (and not worth any additional cost, if you don’t already have the cable).

How would I go about doing that, astro? I should’ve mentioned that the download does begin, and the progress bar moves a bit. So there is definitely a transfer, it is just cut off. A file is even made where is should be, it is just corrupted since it wasn’t completed. If I transfer a small file it will even go through I believe, but if it takes more than two minutes to transfer it will be cut off.

I still have a feeling that it has to do with my comp being reformatted, though.

I agree with your conclusion, but it may be that the error message takes a while to appear; I’ve noticed that peer networking WinXP to Win98 (and vice versa) can involve quite large initial delays, even when the end result is succesful.

It definitely is moving data. One song transfered successfully (I played it and all) but it was a short song- anything else will get that error message.

I set this network up using the XP “Set up Network” thingy, which required me to use a floppy on the 98 comp and everything.

When I set up my LAN (I have a comp running XP and another running 98), I would keep getting errors on both computers because of various problems. I found out that it was all the XP comp’s fault. I forget exactly what I did, but I remember meticulously going through all of the XP comp’s security options, file sharing options, and everything else I could find. I finally fixed it.

Oh, BTW, I’m using a crossover cable that I made in my Cisco 2 Networking class. They’re pretty easy to make if you’re into that kind of thing. And I’d also like to mention that when I was having troubles with this, I posted a thread on here asking for help. I didn’t get as many replies as you, so I guess it’s good that more network-o-philes (?) are coming to the boards.

The assertion that no files are being transferred at all due to the error message is completely false. I get this error message all the time when I transfer files. (Win98 on all the machines.)

Several files get thru, then it hangs and I have an undeletable fragment to deal with. It esp. happens with large files. But it also occurs when I do batches with a lot of small files.

I have tried everthing I can think of. (I am a serious computer geek.) FTP, same problem different error message, even rcp and stuff.

The only fix I found for my situation is to take all the files, rar them into 1.44Meg segments. Transfer the rar files. Test them and resend any that are bad. Then unrar them. (Did I mention that sometimes I don’t get the error but just a bad file copy? So CRC testing is a must.)

To say this is not a satisfactory solution is an understatement.

There is just too many “let’s make it cheap” folks in on everthing from the OS, to the nics, to the hub, etc.

Well, I’ve certainly had such file transfers fail midstream with an error message, and it was usually related to some file integrity check (such as the source was corrupted). But, I have never seen the error message that the “specified network name is no longer available”, but some other “cannot copy file” message (the exact message, I don’t recall).

That particular message would lead me to suspect something else. If a single file passed, that tells me that the PC networking configuration is OK (which was what I originally suspected was not).

So, my guess now is a problem with the hub, one of the cables, or one of the NICs. Either that, or some other problem is causing Windows to display that error message inappropriately.