Unable to resolve some websites all of a sudden

So I’m having a problem that baffles me. All of a sudden, certain websites I was able access perfectly well yesterday now appear to be blocked, that is, any request times out, but downforeveryoneorjustme.com reports them as being up; among them are wikihow.com and drmcninja.com.

The problem occurs across different browsers (Chrome and IE), on different operating systems (Win 8 and Ubuntu), and on different computers, so it must be further downstream somewhere. The settings on the WiFi-router all appear normal, however, nothing’s blocked or anything.

Additionally, I’ve tried changing the DNS to google’s public DNS (, which didn’t help any. I’ve also tried directly accessing the sites via their IPs, sending pings, but nothing comes through; as far as I can see, they’ve vanished from the net…

Any help will be very appreciated!

Forgot to mention, using an online proxy, I can access the sites just fine.

So, for some reason, wikihow now works again, drmcninja still not responding. :confused: