Weird internet glitch (can't get to one website)

There’s a website I need to access many times a day for work. Suddenly yesterday morning the site seems to be down- I get “ERR_CONNECTION_TIMED_OUT” whenever I try to reach it. But I still have FTP access to upload files to the site, and two other people I work with in different parts of my state (I work remotely) could still access the website.

It’s not a firewall or assigned DNS server issue. Every device I have has the same problem- work computer, personal Mac, personal PC, iPad, and phone. I can get to the site on my phone if I turn off wi-fi and use phone data. So I figure it’s either my router or my ISP. I reboot my modem and router, no good.

Logging into my router admin I don’t see any obvious issues, so I call my ISP and ask them if they are blocking the site for some reason. I get a not too helpful tech who confirms he can’t get to the site, either, but he has no idea why. He says maybe something is misconfigured in the ‘pipeline’ between me and the server host I’m trying to reach, and hopefully it should sort itself out eventually. He said to just download a VPN service for now.

So, needing to get to the site, and already having wasted my entire Monday morning trying to troubleshoot it, I downloaded the free version of a VPN called “ProtonVPN” which solved my problem and I’m back in business.

But I’m still wondering what the deal is. Has the server host I’m trying to reach blocked the IP address coming from my ISP for some reason? If so, why do I still have FTP access? Due to complicated company bureaucracy reasons, I can’t easily get in touch with the party that maintains the server that I’m trying to reach (my company owns the server hosting, but another obscure department that would be difficult to track down).

The free level of VPN works ok, but at medium speed it’s a little slow. I can pay for a premium high-speed account I guess, but it would be out of my own pocket most likely. I know VPNs are good to have in general for many reasons, but the VPN service decided to link out of the Netherlands this morning and all my Google search results are in Dutch.

My first instinct would in fact be your DNS. Not on your devices, but on the router. It will likely use your ISP’s DNS server(s), which may be missing an entry for the site in question,bfor whatever reason.

To bypass this, you can either change the DNS on the device you use (Google set DNS devicename). Or, better yet, get to your router’s configuration page and change it there. The most common good ones to try are Google’s and, as well as Clouddlair’s

Are you using a VPN? Many sites that recognize the incoming IP address as belonging to a VPN will not allow you to connect.

Apparently quite a few services were down earlier today, or still are. Some backbone stuff going on. Apple iMessage was down earlier, Github was having problems, WhatsApp was down, and even cell aervice has been affected in some places.

I went several months where I couldn’t get to this very website unless I searched for it on Google. But eventually, it just sorted itself out.

I had a problem logging in to Spotify earlier today. It was still playing on my Roku app, but I couldn’t get into it on my computer to add things to my playlists.

Shopify was having issues today, too.

A few years ago, I had a similar problem getting to the back and public ends of my website. My host had to send me screen shots to convince me they weren’t down. The culprit (verified by Charter/Spectrum) was a severed trunk line in Texas about 50 miles from where the server was located and hundreds of miles from me in California. My host walked me through a VPN set up and that fixed the problem, essentially rerouting my connection to the server (I think - all I cared about was that it worked.)

If you can do a Whois lookup to find the site’s IP address, you can then open the command prompt on your computer, and put in “tracert [IP].” This will show you the route that your computer is trying to take over the internet to the site, and may provide useful information.

That would be my guess. Ages ago I was playing on a small text-MUD and suddenly could not get to it using the URL at home. I could at work, got the IP address there, and could use that to log in at home.

That lasted about a month then the URL started working again. I figured the DNS entry in my ISP was deleted or munged while the one at work – located in Dallas through the company WAN with who-knows-what ISP – was fine.

I did change the DNS on my computer to Google’s (I had done that awhile back to fix a different issue), but I haven’t done it on my router yet. I logged into my router and saw exactly how to change the DNS on there, but held back because I was working and didn’t want to break anything. How does that work with the DNS setting anyway-- if I set it on my device, does that supercede the DNS setting on the router?

I was not using a VPN. As I said in my OP, I had to subscribe to a VPN in order to find a workaround for the problem- I can get to the site with a VPN.

I had tried to ping the IP and got a reply. I just now tried the trace route command-- it takes 15 ‘hops’. Hop 7, 11, 12, 13 and 14 all say ‘Request timed out’. The other hops including the last hop, #15, complete. I don’t know exactly what that means other than something seems to be amiss on the internet path between my ISP and the site.

Oh well, the site is still working fine when I’m connected to the VPN service. I guess I’ll just test periodically with the VPN turned off and see if things ever sort themselves out.

Thanks for the help and advice all!

You sound pretty computer literate. Have you considered editing your HOSTS file to “hardcode” the domain to the IP?

Ignore the poorly formatted first paragraph, you will find better written instructions further down.

I mess around with this file (though I am on a Mac) fairly often, as long as you remember you have edited it you should be good. Certainly cheaper than a VPN service.

Thanks scudsucker, though would that work when a tracert (without the VPN connected) shows that:

So it doesn’t seem like the site is blocked at either end by the host I’m trying to reach or my ISP, it’s a blockage or failure along several points of them internet tubes.

The article you linked to had a link to another article about how to block or reroute internet traffic using the HOSTS file, so I thought “reroute, eh? Maybe I can reroute the bad trace route hops somehow…?”; but when I went to that article it was really just all about how to block sites, not reroute them.

Maybe when I have some itme I can experiment with the HOSTS file on a non-work computer, but for now as a viable workaround I have a free version of a VPN that, while not super fast, seems fast enough for my work needs so far.

It should make a difference, but I am unsure how much.

I reckon it is worth a try. You can always delete the changes.

I edit the HOSTS file for completely different reaaons; most of my changes are to set up “fake” local domains in order to confuse my computer into believing various local domains exist on some other machine. I am a software engineer, and often the testing process requires some level of faking… or as we call it, “mocking”.

That is, of course a greatly simplified description, so if a QA person comes in this thread, please don’t cauterize me!