What the hell?

My sound disappeared from my computer. Now I can’t use any program that creates sound.

This warning came up:

Nullsoft waveOut plug-in v2.2
MMSYSTEM007 There is not enough memory available for this task. Please quite one or more programs and try again.

This isn’t the first time this has happened. Usually I just have to restart my computer three or four times and it goes back to normal. This time, I’ve been restarting constantly since eight this morning and nothing’s happening. I went onto the net and upgraded to v2.3

Zilch, baby.

I’ve got over a gig of free memory, my resource meter says nothing is taxed more than usual, the lowest resource reading is at 82% (which is what it usually reads when I’m not doing anything).

What can I do? Help! I can’t even do work because I’m supposed to be EDITING VIDEOS. No one here knows what the problem is (frickin’ art heads).

Tech lines are proving useless, and I can’t take it anywhere because it’s connected to an AVID suite.

Got this from Google, good luck.

Troubleshooting error “MMSYSTEM007: Not enough memory”
This error may occur on some configurations when you try to play, record, or monitor the VU level. It is a Windows error that probably relates to insufficient memory resources available for the sound card.

Possible Solutions to MMSYSTEM 007 and MMSYSTEM 256 errors:
Make sure the [boot] section of SYSTEM.INI has “drivers=mmsystem.dll” to load the mmsystem drivers on bootup instead of while running an application.
Check that the [drivers] section of SYSTEM.INI has “wave=mmsystem.dll” and “midi=mmsystem.dll”
Try lowering the “FILES=x” line in CONFIG.SYS
Try lowering the “BUFFERS=x” line in CONFIG.SYS to 23, then down to 13 at the lowest.
Don’t use any 16-bit sound drivers. Try not to load any 16-bit sound drivers in CONFIG.SYS

I have the same problem, and have had it since March! I thought it had something to do with WinAmp, so I uninstalled it. I have searched Google and all over the web (including Micosoft’s knowledge base) and still have the problem. MSKB suggests replacing a bunch of .dlls, but I haven’t tried that because I am afraid that something else won’t work if I do that. I still suspect WinAmp because the problem started about the same time I upgraded it to a later version, but as a workaround I just keep rebooting until I get a good boot. It isn’t affecting all my sounds, but the majority of them, like my new mail notification, MP3s, and some others.

A few caveats for posting tech problems (which really don’t belong on the Straight Dope, but we usually answer them anyway):
OS installed
Hardware details (Sound Card? Integrated into mainboard? What brand and model?)
Driver status (what’s showing up in Device Manager? What drivers are you running? Have you recently updated them?)
Try again.

pcubed’s answers, particularly those about freeing conventional memory, may not apply. You may be running NT4 or Win2k. Some apps reguire far more than 23 file handles. There are relatively easy ways to free up conventional memory. I use FILESHIGH=255 and still have over 620kB of free conventional RAM. I’ve never encountered an app that requires more than that. Here’s the critical config settings for freeing up more of the 640kB of conventional RAM:

DBLBUFFER=0 (Assuming your ATAPI/SCSI interfaces doesn’t need doublebuffering, most don’t)


With this setup, I’m getting the aforementioned 620kB free. I dont load much in AUTOEXEC.BAT but if your system requires additional drivers in CONFIG.SYS or TSRs in AUTOEXEC.BAT, use the DEVICEHIGH and LOADHIGH commands to loade them.

My post disappeared. Hmm… Here is what I have in CONFIG.SYS

REM [Header]
REM == PISETUP Begin Delete ==
REM == PISETUP End Delete ==

REM [CD-ROM Drive]

REM [Miscellaneous]

REM [Display

Running Windows 98 1st ed, Soundblaster 64v soundcard, not integrated, AFAIK the latest drivers, no conflicts in device manager, 128MB RAM. I have 2 MSDOS.SYS files, 1 hidden in C:, the other not hidden in C:\WINDOWS. :confused: As you can probably tell, I hate messing with this stuff, but I can if I have to. :slight_smile:

pcubed suggestions never worked

I was just about to install Windows 2000 out of spite when it started working again. I’m not going to look a gift horse in the mouth, but I dread restarting it tomorrow morning. I’m certain I’ll have the same problem.

I’ll tinker around using some of the suggestions.