Why can't I watch videos on Youtube?

I just recently got a new-to-me laptop. I tried to look at a video on Youtube today (first time since getting the laptop) and got the message ‘Hello you either have JavaScript turned off or an old version of Macromedia’s Flash Player’ and there’s a link to download the latest Flash player.

I follow the link, untick the Google Toolbar option, agree to the terms of service, etc. and click ‘Install Now’. It goes to an Adobe Flash Player Install page, thinks about it for awhile, then a message pops up saying ‘Download interrupted. Check your internet connection and try again.’

My internet connection is fine, still connected, so I’m not sure what’s wrong. Oh, and I did confirm that my JavaScript is turned on.

I have Windows XP Professional, Version 2002, Service Pack 2. (I’m fairly ignorant about the techie side of this so please bear with me if I’ve given insufficient information.)

Anybody know what might be the problem? This was previously someone’s work laptop, so could video-watching capability have been disabled somehow to prevent skiving?

Many thanks

What browser are you using? Either way, just downloading Java HERE. If you are running IE or Firefox, it should work. Let us know if it works.

Flash != Java.

Go to Adobe and follow the instructions to download the Flash player. Pay attention to the instructions with respect to any failures.

I run into this exact problem with new computer setups. Install Flash and you’ll be ok. Also, running windows update isn’t a bad idea. An out of the box Dell just purchased for my grandmother displayed the exact same error message. Run the solutions above and you should be fine. If you continue to see anything weird, let us know. There are many people on this board who are overly qualified to handle the situation.


I ran windows update and that seemed to do the trick. (BTW I’m using Internet Explorer.) Where yesterday Flash Player installation just seemed to get hung up, this morning, after running the updates, it installed like a treat.

Many thanks to all replies.

Also, Java != Javascript.

Anyway, problem solved for the OP.