Why does my monitor do this?

I have a laptop that works perfectly fine on its own. However, I recently added an external monitor, keyboard, and mouse, routing it through a port extender. Back when it was my primary computer, I used it with the same setup, but a different monitor. It worked fine back then.

Now, though, it’s a little wonky. One of the primary uses of this machine is to run my Everquest trader. For those not familiar with Everquest, it’s an on-line game, with it’s own marketplace and economy. A trader simply sits in a bazaar like place, hawking my wares for hours on end. As such, I have the game up and running for many hours. While I do that, I sometimes minimize the game so I can run Web searches, browse the SD, or whatever.

Problem is, when I minimize the EQ screen, the monitor starts acting up. If I don’t have my Windows desktop resolution and the game resolution set exactly the same, minimizing the game causes the whole screen to go black, and the only way out is to reboot. If they’re set the same, I can minimize, but the image on the screen is then distorted. You can see an example here.

This only happens if I’m running EQ in a small or minimized window.

If I’m in the browser, hitting “refresh” fixes the image in the browser. But if I navigate back and forth, it screws up again.

I’ve downloaded & installed the newest drivers for both the videocard (ATI Mobility M4) and the monitor (some Sony piece of crap my husband bought). I’ve rebooted multiple times. If I remove the monitor and just use the laptop screen, I don’t have this problem. Help!


Noone? Nobody can even venture a guess?

I would initially have said simply replace the monitor with a unit more responsive to res and frequency mode shifting, but given the pic you displayed if doesn’t look like an external monitor issue, but more of a driver issue as the video output actually looks mangled. I suppose it could still be a monitor resolution issue of some kind but it looks more like a driver problem with mode shifting.

Anyway, replace the external monitor with another one and see if the problem persists. If it does, it’s not a monitor hardware issue but more of a driver issue.

Depending on your OS you might want to try installing the latest version of the windows DX drivers available for your system.

Also, as a suggestion, I know nothing about Everquest, but many games of this kind have an extensive video setup submenu that can adjust resolution, textures, lighting, special effects etc. You might want to try playing with that to see if that affects the mode shifting. In looking at the net it seems you possibly have an older version of Everquest, and apparently newer ones are flexible enough not to require resolution shifts when buying and selling equipment, so upgrading may solve your problem.

Yup, that screenshot is FUBAR. I have a similar driver issue with my Hauppauge WinTV card. Every time I run the TV app it screws up my screen fonts and I need to reboot. Sorry I don’t know how to fix driver issues.

Athena, did you update the video driver from ATI, or from your laptop mfgr? Laptop video chipsets (especially IBMs and Toshibas running ATI Mobility) are pretty notorious for being fairly proprietary in terms of the drivers they can best utilize - if your system shipped with a video driver specific to your manufacturer, and then you updated to a generic ATI driver, the new driver may have either corrupted the old one, or may just not communicate properly with your extenal monitor output.

My best suggestion is to contact your laptop vendor for support. They will probably recommend that you update your video driver from the laptop manufacturer’s site, even if the driver is from a prior date than the last ATI driver update.

Good luck!

The driver is from the laptop manufacturer’s (Dell) site, not from ATI itself. I’ve found inconsistencies in the past and have always used Dell’s rather than the generic ones because of that.

As far as Everquest being an old version - no. It’s an on-line game that get updates every time I log on. There is no “old version” of it.

Well, I can suggest you convert that image to .gif to save bandwidth…
It looks to me like not all the video settings got re-set on switching. (i.e., palette depth, buffer clearing, etc). You could try setting the windows and EQ colour depth to be the same, but I think the real problem is the video driver. Sometimes stuff like this happens with new drivers, then later disappears. Have you tried checking either some ATI or EQ forums? You’re probably not the first this has happened to.