Windows Media Center fast forward problem.

I built a Vista Media Center machine only for recording TV shows with an antenna. It works well recording stuff, but I have a problem that I just can figure out.

When we go to watch a show sometimes the fast forward will freeze up the media center. I’ve tried using the keyboard, mouse and remote and they all do the same thing. I don’t have any other programs running, I don’t use the machine for anything else. I’ve also made sure all the updates for the graphics card, Vista and the tuner have been updated. I’ve also asked on other boards that are more dedicated to Media Center and no one replied.

I’d really like to be able to get this fixed as the new season has already started and it’s quite annoying to have to either watch the programs without skipping or hope for the best. I’ve noticed that it seems that some channels it doesn’t happen at all, but for most programs it does. Any ideas except for reinstalling Vista?

What exactly happens? The picture freezes? The entire VMC app lock up? Does it recover in any way, maybe by pushing play, pause, etc? Is it a hard crash so that you have to reboot, or does it dump you to the desktop? Do you get any type of error message? Are you using any third party codecs or codec packs? Are they up to date?

Does this happen on regular video files, or only on recorded TV shows? Does it happen when you time shift a show? Are you recording to the main hard drive, another drive, a network drive? Are you running SP1?

The picture freezes and no sound comes out. I’ve let it set for a minute or two and nothing happens. I can’t use any other functions of Media Center and I end up using Ctrl-Alt-Del to get rid of the application. I don’t need to reboot, just restart Media Center and replay it. However I’ve noticed that if it happens once in that file it always does it. I got it to work fine last week for House no problems and I thought it was working fine, then last night it froze again. It doesn’t give me any type of error message, just stops playing.

I’m not 100% that I’ve done SP1, but I think I have as I just let it do a lot of installs a week ago. I’m not sure on the codec as I don’t remember installing any except what came from Vista and maybe the graphics card if they even do such a thing. This past week I had it look up and see if there were any new drivers for the Nvidia card, updates for MC, and others.

I do not have it hooked up to the internet except when I need to download the new guide from Microsoft, I don’t use the internet at all so there shouldn’t be any malware or anything like that. I have to run a cable to the router every time.

I’ve never tried to watch a show while it’s being recorded as I’m afraid that it will stop recording. I don’t use the machine for anything else except recording TV on the main HD. This thing has given me nothing but trouble, I was hoping it would be pretty easy. I really wish someone would make a Tivo without having to pay for the service.

It’s definitely a pain when something like this just doesn’t work. I have an HTPC as well running Vista Ultimate, thankfully this problem hasn’t happened to me.

My first suggestion would be to try and install the latest K-lite codec pack. If that doesn’t work, try setting your recorder setting a notch lower. Maybe the bitrate is too much for your video/audio hardware to handle?

Finally, try changing the forward and skip rate either by downloading the the vista tweak program (don’t have it on me, but I’ll post a link to it tonight) or by changing it on the registry itself (you can google instructions for this easily).

I hope you can figure this out, there’s nothing quite like an HTPC (that works :slight_smile: ). I’ve got mine hooked up to my network and can watch and download movies from my netflix account, edit my DVD queu and have access to a large amount of online content. I also have my DVD collection on my hard drive, so there’s no need to hunt down the actual discs if I fell like watching something. And all of this is accessible through vista media center.

Some boards that might also be able to help you are the Green button and the Digital lifestyle.

Re-installing Vista might be the last option you have, but give the options above a try first.

P.S This is what I was tlkaing about MCE customizer:

I installed the full version of the K-lite codec. That didn’t seem to help with the program I recorded Monday. How do I set the recorder a notch lower?

I did however play with it for a bit tonight. It seems to be the way it recorded, or I’m guessing that. I tried playing the two shows that I have, the one I could FF through, the other I couldn’t. I tried to play them both through Media player. They both played fine, but when I tried to FF through the one that didn’t work with the slider it locked up MP as well, the other file worked fine.

I’m not all that up to date on how the codec work, way too confusing for me. Is there one that I should try to make sure it works properly? And is there a way to fix the files so that I can FF through them? I don’t keep my shows, but it might help in the future.

Oh I did try The Green Button first, they didn’t respond at all. I also tried to search through their forums but couldn’t find what I was looking for.

You can change your recording settings through the tasks -> Settings menu. I believe it’s under TV. Try setting the recording quality to better instead of best, or a notch lower than whatever you have it at.

There is another possible solution and it involves essentially “fixing” the file. In fact, I don’t know why I didn’t think of this before. I think this is your best option short of re-installing vista.

Try downloading and installing the vista MCE toolbox. What it does is it automatically re-encodes recorded shows to whatever format you want. You can also have it strip out commercials for you as well whilst re-encoding.

Not only is that likely to fix your problem, it will also save you hard drive space (specially if you re-encode to something like Divx). I don’t know why I didn’t think of this before, I love this plugin.
If this works out for oyu, remember to install the Netflix app too, if you have a netflix account! :slight_smile:

dvrmstoolbox also does the same thing.