Windows Media Player help needed!

WMP isn’t recognizing any USB device I plug in to Sync music files. The computer reads them just fine. I’ve shut down WMP and restarted the computer as well, but no dice. I’ve gone to the Help tab and did what it says to do to set up a device. Again, no luck.

Anybody got some ideas? I need to get my rock on with my mp3 player and USB stick.

Forgot: I think its version 12.

Nobody? Anybody? Bueller?

Hah! I’ve stumped The Dope!

Where is my prize?

A little research (in this case googling WMP 12 USB) brings up a variety of results that may be related.

One, for example, is that on Windows 8 machines, USB devices detected by Windows as “local disk” and not “removable media”, WMP 12 is not going to see it as a valid sync location.

Whether or not the USB device is detected as one or the other seems to depend on several variables…manufacturer, manufacture date etc. Is this Windows 8 and does it detect your USB drive as “local disk” or “removable media”? If you have tried drives recognized as both by Windows and still no joy then I guess you are both aware of this and the fact that neither resolves the problem.

Don’t upgrade to W10. WMP is gone in it.

There are KB patches to add it back in, but (in my case) they don’t seem to work reliably installing the Media Transfer Protocol driver. So WMP doesn’t mount or see the phone anyway.

But I can play music already stored on the computer, so that’s good.

I had Windows Media Player in W10 when I upgraded from Windows 7. If it doesn’t come with Windows 10, you can definitely go and download it.

I actually switched my default player back to Media Player because it loaded faster and could handle a lot more video types.