Windows Media Player question (possibly stupid and easy)

OK. In this thread, I was swayed by yosemitebabe’s praise of the Windows version of iTunes, so I went ahead and downloaded it.

It’s fantastic! I’m very happy with it, and would like to use it as my default player for mp3s, and also I’d like it to be the default when I insert an audio CD.

Windows Media Player seems to really hate that idea. I’ve done everything I can think of, but it still associates itself with everything and even hijacks audio CDs and mp3s when I have iTunes open.

I have gone into the Options menu in WMP, and deselected every file type listed. Still no result. Is there something painfully obvious that I’m missing?

This is for WMP version, and I’m running Windows XP Pro.

Thank you!

You need to associate autorun with this program. Got to My Computer or start Windows Explorer. Right click on the CD drive letter and select properties. There you will see a tab for Autorun or something like that (mine is French and says Exécution automatique). Select the type of content (Music CDs and Audio CDs) and set it to your program, if available from the list.

If the program is not available in the list, check to see whether your it has an option to associate itself with CDs (not just MP3 or .cda files).

Barring that, there may be a registry key that can be modified, but that’s beyond my expertise. Good luck.

Choose an MP3 file in a folder. Right-click on it and choose “Open With” and pick iTunes from the list. Make sure that the checkbox for “Always use the selected program to open this kind of file” is checked.


Go into WMP and deselect all the file types again.
Now, open any folder and click on Tools>Folder Options>File Types.
From here you can associate iTunes with you music files.

If you only want to associate 2~3 files types then GuanoLad’s way is quicker. Just remember to deselect file types again in WMP first (yeah, I hate WMP too).