Windows Update: Microsoft has no updates newer than Feb 14?!

I just tried running Windows Update for the first time since February 14. I know, I know - I’ve been busy. I used to do it at least monthly.

But after scanning for updates, the message was that there were no updates available. No critical patches, no noncritical, nothing. Can this be?

I never deliberately enabled automatic update, and my installation history shows the February 14 updates were the last ones installed.

If there have been updates, why in the world would they say there weren’t?

Also using Norton antivirus. And my connection is via DirecWay satellite - this changed shortly after Feb 14 - any way this could prevent update from identifying needed updates? Note, update didn’t appear to refuse to work; I got the familiar window that eventually said 100% complete scanning for updates.

Which Windows OS are you using?

I’m on XP, I downloaded one yesterday, a criticial update, and I check fairly frequently. I’m sure I’ve checked many times since Feb 14.

We’re still on 98 here at work and there was a critical update today.

I’ve been getting the no update thing, too. I’m running Windows2000 Professional.

I’m using XP Home, and had an update to install this morning.

There are a number of problems that can cause Windows Update to erroneously report that there are no new updates available.

Make sure that your date and time are set correctly. Check that this registry entry is correct. You could also try updating the scripting engine. You can find other potential solutions by searching the Microsoft Knowledge Base.

I downloaded a critical update for 2000 Professional about 3/4 hours ago.

Me, too. 2000Pro and there was an update waiting for me this morning.

Thanks, folks. But I’m still not getting anywhere.

I am using Windows XP Pro v5.1.2600 on a Dell 4600 a little over a year old.

>Make sure that your date and time are set correctly.
>Check that this registry entry is correct.
This isn’t an XP issue according to Microsoft. 98 and, I think, ME.
>You could also try updating the scripting engine.
OK, just did that per MS instructions.
>You can find other potential solutions by searching the Microsoft Knowledge Base.
They say also fixed by downloading and installing latest version of IE, so I did that. Didn’t spot anything else that sounded appropriate, at least not without more study.

I tried using the Help and Support Center from my Start menu, and also tried starting it from the Microsoft web site. Same result - scan reports 0% complete for a few minutes, then suddenly 100% complete with “no updates” message. Some of the Microsoft Knowledge Base entries specifically describe problems where the 0% never changes. I don’t see any progress bar anywhere and don’t remember where specifically to look for it.

Also tried starting this from the Microsoft web site using Netscape as the browser; this takes a few minutes to load a completely blank page and report “done” on the status bar.

My internet connection is through my home network - is there any reason that would stop it? This includes a firewall router with firewall features turned off, a DirecWay DW6000 satellite modem, and a layer of NAT in each.
I also use Norton Antivirus which is up to date.

BTW I’ve had trouble with what I think are unwelcomed programs installing themselves on my machine, as well as browser redirection, zillions of popups, etc. Most recently I got rid of PowerScan 1.1 by Integrated Search Technologies, by deleting its folder in the Programs folder. Beats me how I’m supposed to get rid of it - Add/Remove Programs doesn’t list it, and clicking on its own Uninstall box tries to download and run another .exe from their site, which I then refuse. But I have not seen search engine redirection, cpu busy, or other signs so I have not yet done the formidable steps described in the posting about If you have computer problems (or whatever it says).

Any help would be greatly appreciated! Thanks!

From a quick web search(meaning I’m not sure) Powerscan seems to be spyware. First thing I’d do is install and run Ad-Aware and Spybot



See if that helps.

Yeah, I had this one waiting for me this morning. I thought Microsoft had forgotten me.

Ditto. Was the first one in quite a while, actually.

This page suggest an SSL problem solved by

God, what a nightmare.

I installed and ran AdAware and it identified and fixed 105 problems. Then I installed and ran SpyBot and it identified and fixed 19 more problems. PowerScan has now fortunately disappeared (BOTH programs claimed to find and remove it).

Not long ago I bought ZoneAlarm version 3 (I mean I actually bought shrinkwrap at Best Buy) and spent all of four hours trying to make it work. I could not browse SDMB and the CNN news site unless I turned off EVERY SINGLE FEATURE of ZoneAlarm. Thinking maybe something was wrong I looked again and also found and bought version 4. Spent more hours but again had to disable every feature. So I gave up on this one.

I really don’t know how far to push this. All I want is to practice reasonable dilligence and yet be able to do simple web browsing including using my web-based bill payment service and email service. I don’t want to use Outlook, don’t want to play games, don’t want to use VPN, and don’t use any media content. You’d think that would be a fair expectation. How many hours per week should one expect to spend on internet security?

But still no Windows Updates. Still the same behavior.

Anybody have any other ideas? If you suggest something that fixes this, you can’t imagine how grateful I’ll be!

>Please verify that your computer’s date and time are accurate and that the Internet Explorer language option is not empty.

Did that. Both were already OK.

>Please delete the Internet cache and cookies.

  1. Click “Tools” and then select “Internet Options”.
  2. Click “Delete Cookies”.
  3. Click “Delete Files”.

I already do that a few times a week because I don’t trust those things.

But thanks for the suggestion!


That is, Windows Update now works automatically. I’m filing the above postings for future reference - Thanks, everybody!

What fixed my problem? I posted my query on the satellite forum, thinking my new DirecWay internet connection could be the problem. People there said my Linksys BEFSX41 router’s default MTU setting of 1500 would not allow Update to work, and I should use 1460 instead. So I made the change and now it works!

My understanding of what routers do is pretty hazy, and it’s not helped by various web sites and textbooks that each seem to describe them differently. Generally my understanding is that a router digests each packet by stripping and rebuilding the header information according to various changeable rules, so for instance it can use a translation table to change the destination address, or it can block packets with undesireable headers. Then it passes each packet along (the router has a WAN side and a LAN side and everything it does involves passing packets between sides). It does this according to different rules for each direction, and generally treats the WAN side as potentially untrustworthy. I have not a clue what MTU is in particular.

I highly recommend BroadbandReports to anyone interested. It’s free (if you want a slightly reduced access account which, for me, has been perfectly satisfactory). This is probably the 3rd of 4th time I’ve gotten some absolutely obscure issue fixed.

I’ll second… (Formerly being a good place for info on networking and internet access… They’ve got lots of forums broken down by brand and a good sized community that has no trouble calling BS when someone gives bad advice. Definitely worth checking out.