Can anyone access ? I’ve tried with Opera 7 under Windows ME and links under Linux (I have a dual-boot machine), I’ve tried to ping them ( with two different utilities (Sam Spade under WinME, ping under Linux), and all four programs have insisted they can’t reach the site at all.

Okay. I’m not paranoid yet. is sold bandwidth by XS4ALL, a noted access provider in the Netherlands known for its strong belief in free expression. The Netherlands is rational enough to block crazy cults from using copyright law to block free speech. Andreas Heldal-Lund is one of the biggest critics in the world, and he wouldn’t just stop the biggest anti-Scientology site online. It simply isn’t possible. I can access alt.religion.scientology (gotta love a newsfeed :)) and, so far, nobody has posted anything about dying. A.R.S. is a high-volume group that is considered a high priority by Heldal-Lund and his group.

So the problem must be mine. But … how? Has a big pipe broke somewhere between me and the Netherlands? Is my ISP somehow doing something evil? I need external data. So, regardless of your comprehension of my above paragraph, please give me some info on how well you can access :slight_smile:

I can get to it fine. Using IE 6.0SP1 on Win2K.

I was able to get in. Maybe They don’t want you to know…

Here we go down a rabbit hole…

I’m still trying. It takes a while for my browser to give up (I’m using links on Linux, BTW), but it’s been a little bit since I started this last time. It doesn’t look good.

Nope. Didn’t work this time, didn’t work the last few times. Maybe more data points will reveal a pattern. Maybe it’s just a regional outage related to certain locally important machines going down. I hope so.

I didn’t read the whole article, but there is a link to a Yale site that says the xenu page is “Blocked by Wayback Machine”.

No problem getting to it with Mozilla under Win XP.

I’ve tried with links, konqueror and mozilla - works in all of them

Can’t ping them though.

your link works fine on this laptop.
win XP professional if that helps.

Okay. I don’t think it’s browser- or OS-dependent now. (Thanks, guys. :)) It must just be my shoddy connection. I still can’t reach it.

I’ll have to hit the library today. I gotta localize this problem.

BTW, the Wayback Machine is the Internet Archive. It refuses to archive’s web pages because of the Cult of Scientology’s pseudo-legal bulldogs.

I can reach it from the library. IIRC, the library uses DSL (or another always-on broadband) while I’m stuck behind dialup. So I think it’s pretty much just me (or a small subset of all users in the area, which I happen to fall into). That makes me happy, of course, but really doesn’t get me much closer to solving this thing.

I still can’t reach it, but I enjoy knowing others can. :slight_smile:

My WAG is that your ISP has been forced to block access the the site.

Or, double check your ‘rhosts’ file. (In Windows, it’s a hiden system file, don’t remember enough about Linux to remember where it puts it.)

It could be there’s an entry in that file that’s pointing your browsers to an invalid/wrong place. I dunno how the rhosts file for both OS’es would have gotten screwed up though.

<< It’s not hard to meet expenses, they’re everywhere. >>

Desmostylus: That’s the conclusion this odd series of events is forcing me to. This weekend, I’ll be at the home of a friend who buys access from the same ISP I do (, to be specific) and I’ll try it from there.

Nightsong: I don’t know how both OSes would be affected, either, so I don’t put much stock in your hypothesis.

If this is an issue with my ISP, and I’m not convinced of that at all yet, I’ll probably have to send a few emails. Not threats, mind you, just a request for clarifications of their policy regarding sites critical of criminal organizations.

Maybe they’ll block the FBI next.

IIRC Etisalat (crap monolithic useless state telco) blocks access to it here. I can’t check, because I’m currently in the free zone where the internet is uncensored [yay!]

Quite why a Muslim country would want to block a site legitimately attempting to expose one of the world’s most notoriously corrupt, evil, irreligious stains on the very name of “faith” or “religion” is beyond me.

Perhaps they are too stupid to understand what it is.

I do believe it’s my ISP. I couldn’t access the page from my friend’s house, which, in my mind, firmly rules out any weirdness on the part of my computer. Since other people, in addition to me when I try to access it from the library, can access the site, it cannot be a problem at their end. So I’m left with one conclusion: is blocking access to

So I have to send an email. As I said, this will not be a flame or a threat. This will be a reqest for a clarification of policy. I’ll have to search through the website to find the correct address, of course, and I’ll probably have to deal with plenty of autorepliers and employess powerless to explain corporate policy.

Wish me luck.

I suspect that the response you’ll get is that it’s their policy to comply with court orders, or that they’ve received a scary letter and they’re protecting their asses just in case.

You’re probably already aware of Scientology’s use of the court system. See for example.

I’m aware of that. I know of the Cult’s legal pitbulls and how they are trained. But this is fairly recent, as far as I can tell. I hope the emails I’ve just sent will give me some insight.

This is very interesting. If your ISP is blocking the site, this makes for a good Slashdot article.