Another goofy computer problem

Dell desktop running WinXP Home, 2 GB RAM, latest Firebox browser. For about a week now, when visiting one of two forums I frequent, run into a new-for-me problem. Not all the time, which of course makes it more difficult to diagnose

Now and then, while scrolling down through the list of threads, or scrolling down through a post, it will suddenly stop letting me move up or down with the mouse scroll button, the PgUp or PgDown buttons, or or the up or down arrows. It will still scroll up or down dragging the scroll bar bar or using the scroll bar up or down arrows.

This only happens after I have been doing this for a while in the forums.

If I click on anything the screen, often (but not always), it will highlight all the text.

If I close the browser, cannot open any desktop icon by clicking on it, or do much else. If I try to “Turn Off Computer” with a “Restart,” nothing happens. Only if I turn it off completely, wait 30 seconds, and boot up again, is the situation corrected. Until, of course, next time it does that.

No new software or programs installed recently. Anti-virus and three anti-spyware programs run, no problems, nor does that fix the problem.

Anybody got an inkling as to what is causing this?

This is a long shot, but have you tried using a different keyboard and mouse? It could be a hardware problem with those devices.

Other than that, I got nothing.

It’s pretty unlikely that both the keyboard and the mouse would undergo simultaneous hardware failures consistently.

I think this happens when the computer is too busy to handle your input in a timely fashion. I like to blame it on misbehaving javascript in the page I’m loading. So, try disabling javascript in your browser and see if that helps. If not, then I dunno.

True - I was guessing it could be one or the other, but not both. It’s just easier to swap out both, if spares are available.

And I did say it was a long shot :slight_smile:

Similar things have happened to me.
The non-scrolling seems mainly to be due to a slow-loading page.
The ‘select everything’ I put down to the touchpad that initially had a mind of it’s own but in general ‘learned’ to behave.
New software and updates sometimes upsets this for a while - a few hours at most usually. It is most often highlighted by it auto-selecting on buttons or links when the cursor just passes over them. Or auto selecting half a page of text as the cursor traverses it.

When booting into other profiles that are rarely used this behaviour is much worse - it hasn’t ‘learned’ in these profiles. The Admin one is worst as this is the least used one.

It did seem to happen more with Firefox 3B5 but RC1 seems to be less affected.
It also displays the same behaviour using Safari, but less so.

Toshiba Equium 100A/Vista HP.

Firefox on Ubuntu, home built desktop does not display this behaviour.

Seemed like a long shot to me too, but what the heck. I forget to mention that that my keyboard and mouse (actually, a Logitech trackball) are wireless.

The trackball lets me know without question when the battery needs changing, as the mouse cursor gets very sluggish. The keyboard batteries, however, have latsted for more than a year, which is a surprise. I checked them and they are up to full voltage, so I swapped the thing with a wired keyboard.

I have a whole bunch of things using USB ports, some of which go to the box, some to a powered hub, and some to a unpowered hub. I suppose all that could confuse the computer. :smiley:

Oddly enough, that seems to have solved the problem, although I can’t imagine why. It’s only been one day, so will keep my fingers crossed. If it comes back, will swap the mouse too, as I seem to have a drawerfull of mouses. Mice? Mousies?

We’ll see.