Camera-computer connectivity problem

I’ve been using my digital camera for a while and downloading images without any problems whatsoever until last week. But now whenever I connect the camera into my PC’s USB there’s no response from either device; the usual software doesn’t load and the camera doesn’t go into transfer mode. I’ve tried the camera (with my USB cable) on my friend’s computer and it works there, so the problem is with my computer.

What could go wrong for it to suddenly stop working like this? And is there anything I can do?

I’m using Windows ME.


Reinstall the camera drivers. Check the Device Manager; if they are listed there, remove them. Or check Add/Remove Programs; if there, remove them. Then reboot, and plug the camera into the USB port (make sure the camera is on, and in transfer mode). Windows should see the new device and install the drivers again. It may ask for the CD-ROM that came with the camera, so have it handy. You may also want to check the camera manufacturer’s website to see if they have issues updated drivers for your camera.

Fear Itself: Sorry, I forgot to mention that I already tried uninstalling and reinstalling the driver…but still no luck. No response at startup either.

Have you tried using a card reader?

This may be a dumb question but, have you tried a different USB port?
I fried one of my ports (on an old mobo) and this left only one working port.

Yep, it has two USB ports and I’ve tried 'em both, but still nothing.

I haven’t tried a card reader though. I guess that’ll be a semi-last resort.

This is unbelievably frustrating; one night it was working and the next it wasn’t and I hadn’t done anything unusual with it.

It could be the USB cable itself. I had a similar problem with my MP3 player. The contacts in the connector had corroded. Unfortunately, it was on the (proprietary) connector that attached to the camera, so when cleaning attempts failed, all I could do was buy a new one.

I thought so too, which is why I brought my USB cable along to my friend’s place to try there and it worked fine.


Whenever Windows stops recognizing devices plugged into the USB ports, it’s almost always the USB drivers themselves (esp. bad in Win98 first edition and WinME). Here’s how I always fix them:

Disconnect the offending printer or camera or whatefer and uninstall whatever software/drivers you can from Add/Remove programs.
Right-click on My Computer, left click on Properties. Click on the Device Manager tab and look for the USB Devices item (I believe USB may be spelled out as Universal Serial Bus devices in older OSes - don’t have a 98 or ME system handy right now to check). Click the plus sign next to it, and you should see one or more “USB Root Hubs”. Highlight each one in turn and hit the “Remove” button at the bottom. Close all the open windows, and it will normally have you reboot. Reboot, and have your WinME disk handy. When it reboots, it should detect the USB Root hub(s) and install the drivers for it.

When all that is done, re-install the USB device per the manufacturer’s instructions (some require that their software be installed before you plug the device in the first time, some have you plug the device in and just point it to the drivers on the CD first - check the documentation).

If, after removal, the USB Root Hub isn’t redetected, you may have a hardware issue with the USB ports (could be something that could be resolved by clearing NVRAM if that is an option, resetting the BIOS settings to factory defaults, or just disabling the USB ports in the BIOS, reboot, re-enable the USB ports in BIOS, reboot again).

Ack! I missed that bit of your OP. Don’t mind me.

Critter42 gives good advice. I’d certainly try that. I’ll add that your success might be better if you do this in Safe Mode. If there are multiple installations of the USB Root Hub and other associated hardware that may be causing problems, you’ll only see them in Safe Mode.