Certain Webpages never load

For some reason, certain webpages just refuse to ever load on my PC. Two prime examples I can think of right now are Apple.com and Cnn.com. CNN.com will load the title bar, so I can tell it’s connecting, but nothing shows up in the window. Apple.com will load up the little navigation menu at the top of their page, and nothing more. I oculd leave these to try and load overnight and still nothing ever happens. I know it’s localized to my PC because my laptop and other computers on the same connection can load them just fine.

I downloaded and reinstalled IE 6, and even disabled my Norton Personal Firewall to see if eitherof those did anything…nope, not a thing.

Any suggestions on what to do?

First get the page up and press shift and the refresh button to force the page to refresh. If this works then change your setting in Tools>Internet Options>General>Settings to check for newer versions of stored pages every visit to the page. This worked for me when I had crap versions in my cache. If shift>refresh doesn’t work that isn’t the problem.

No no, that didn’t work at all. The status bar at the bottom kind of starts to load, one or two green squares appear, and then it just stops.

I’ve had that happen to me. I don’t know how to fix it, but I’ve found it goes away after a while.

Have those pages EVER worked on your particular pc?

I think they might have at one point. The thing is less than a year old, so it shouldn’t have any problems like this.

Have you tried clearing your cache and offline files ?

Tools/Internet Options/Delete Files.


Tools/Internet Options/Settings:

Set it to “Every Visit to Page”

No no, it’s not the cache, I mean, I can’t have a cache of a page I’ve never really been to, can I? Also, it was already set to “every visit to page.”


Try to determine whether your network cannot reach those pages correctly, or just the browser.

What OS are you on ?

In Win9x/ME:

C:>ping cnn.com

In WinXP:
C:>ping cnn.com

Do you get a good response time ? If so, it’s probably some browser setting. If not, it’s probably some network setting.

Browser setting:

Tools/Internet Options/Security/Custom Level/Active Scripting/Enable.

If that doesn’t work, set all Active-X and Scripting to Enable.
(note: this is a security risk. Use it only to test. Load only cnn.com and no other site.)

See if that helps. Report back.

OK, I pinged cnn.com, and all four tries timed out, I tried apple.com, and I got a reply back about as fast as when I pinged straightdope.com. This kinda goesalong with what I’m seeing, as apple.com does start to load, but never gets past the banner at the top of the page, wheras cnn.com really doesn’t load at all.

If it is a network setting, then it’s a network setting on my PC, becase, as said, my laptop can access them fine, as can other computers on the same network connection.

Also, active scripting is enabled, and I tried the active X thing but to no avail, apparantly.

What operating system are you running?

You might want to take a look in your hosts file?
Do a file search on your computer for a file called “hosts” (not hosts.sam that’s just a sample file)… in your C:\Windows directory. If you find one open it with notepad and delete any reference to that address. (just the line of text).

To open with notepad hilight the file, right click while pressing the shift key and select “open with”… then choose notepad from the window that opens. Do not check the “always open with” option.

Look for a file called HOSTS (and only HOSTS, not HOSTS.SAM)


If you’re on XP (or NT/2000 for that matter) then the HOSTS file referred to earlier is in C:\Windows\System32\Drivers\etc instead of C:\Windows.


Yeah, I’m running WinXP, and nope, no cnn or apple in the hosts file, just full of a bunch of known ad sites and pop-up things.

What type of internet connection do you have and how to you share the connection between the computers?

I have seen this type of problem before (websites specific to a computer that do not load) being caused by an ADSL Line using PPoE and it not being configured properly.

Come on, I think it is unlikely there is a connectivity problem here. The browser is probably getting content, but choking on it when it tries to make sense of it or render it. Here is what you do to confirm that:

Open a command prompt and type
telnet www.cnn.com 80

The screen will probably just blank, or nothing will happen. At that point, type
If the content most of the time spits right out, ending with </html>, then your browser is just having a problem processing the content, not receiving it.

After that I have no clue. Disable JavaScript or some crap like that.

OK, so when I telnet cnn.com, I get some gobbilty gook (yeah yeah, I know it’s HTML code, but to me, that’s gobbilty gook) and then it ends with a message saying connection to host lost. I tried a few times and noticed that the connection doesn’t always get severed at the same point, i.e., the last line of HTML displayed is not always the same, and I never get the full page ending with the </html>.

Apple.com, I get the whole page, ending with </html> then the connection is lost, and the same thing with straightdope.com, a page I can always access.

Try it with a different browser, I would recommend opera 7.x or netscape.

OK, so I tried dgm6780’s suggestion of Opera, and I ran into a problem on installation. As soon as the Java packet was done installing, it said “Installation Completed Successfully”, and then went back to Opera’s installation, and I got an error saying "The instruction at “ox771c741a” referenced a memory at “0x00163960”. The memory could not be “read”. CLick ok to terminate the program. Meanwhile, Opera finishes installing and says that it is complete and successful, which is apparatnyl a lie.

Man oh man, this thing keeps getting worse. Well, now maybe the problem is localized, something seems to bve wrong with my Java, or where my Java is, or something.

Oh, and Opera can’t load the pages, either, apparantly.

Could be your DNS settings, there were a lot of topics on that…try juno.com free ISP & see if that works, if it does, then its probably your dns settings with your present ISP or one of the hubs or computers on the routes to those sites is offline. Youd have to do a traceroute.

How could it be DNS settings if the name is resolved and the connection made in the first place?

bouv, the fact that you lose the connection every time you do that over telnet is normal. By and large, HTTP connections are not kept open once a request has been answered.

Now, the fact that you don’t always get the full body of the page is worrisome. If it’s true, then I guess you are having connectivity problems. Try telnetting into the web servers again, but don’t type anything. See how long it takes each one to close the connection. Handy’s traceroute suggestion is also a good one. It will show you any huge problems talking to the servers.