Change name associated with Gmail account on iPhone

I have researched this online, and implemented the solution given, but had no luck; hoping a clever Doper can help me solve this.

Emails sent through Gmail on a computer show up as coming from “My Name”, with the email as

Emails sent from my iPhone 5SE (latest iOS) are shown as coming from “Holidays In The United States” with the email as

I have gone into settings and confirmed that the name on the account is TSBG. I even retyped it. But no, it’s still that damn “Holidays In The United States” when I compose as email.

Please help.

Look in your address book (Contacts) and make sure there’s no entry for “Holidays In The United States”

There isn’t.

Ok, have you looked in Settings->Mail-> the GMail account?

Yes, done that.

Are you using the iPhone Mail app, or the actual Gmail app?

The iPhone mail app.

Are you married to the Mail app? I mean would you be willing to use the Gmail app if using it solved your problem? Not that I’m sure it would, but it’s worth a try, even if only as an experiment to see if it still does it.

I’m not emotionally committed to it. I’ll install the Gmail app and try that, though I’m annoyed that I have to.

I switched an account to my name on a used cell phone and the only way I could do it was to reset the phone (Android) to default factory settings. That removed all personal data. Had to re-enter everything, but it cleared out the old account information.

“Holidays in the United States” is a calendar you’re using somewhere. Check online in your Google Calendar and then look on your phone too.

First, I’d try unsubscribing from “Holidays in the United States” in your Google Calendar.

Then, in Contacts on your iPhone, open up your own contact. Is your Gmail listed as an email for your own contact? If not, put it in. Just to be clear, I’m talking about the Contacts app, not Settings > Mail, Contacts, Calendars > your Gmail Account.

OK, I unsubscribed to the Holidays calendar and added my correct email address to my own contact, restarted the phone, and it’s still the same.

Are you using Exchange?

Compose an email to yourself and when that email comes up in the suggestions list, tap the circled “i” info button to the right of it, then tap “Remove From Recents.”

That did it. Thank you!

That’s what I love about Apple products. Everything is so straightforward and intuitive. No weird hacks or unexpected interactions. No esoteric knowledge needed to use one. Jobs and his disciples are such geniuses.


Very constructive.

I actually agree with LSL Guy. I have been an Apple guy for 30 years, since my first computer. I have been wondering for a couple years now why I pay the premium. zbuzz, I really appreciate the help, but I also think I shouldn’t have needed it. Maybe I’m just veering into old-fart territory, but I find the products increasingly non-intuitive and the “help” on offer from the company to be useless.

You’re veering into old-fart territory.