Email responses

I selected “never” for receiving emails related to my posts. I saved the selection of never. I keep getting emails. Help!

Is Activity Summary checked?

And where might I find

Where might I find Activity Box … thanks

If you go to summary > preferences > emails

There is a first set of options on email, the Activity summary is near the bottom -

Activity Summary

When I don’t visit here, send me an email summary of popular topics and replies

Which you’d want to turn off and make sure to save changes.

One thing I’m not sure of, but the Notifications option is browser specific - I don’t know if the same applies to the email settings, but if you use more than one browser, you may want to check that as well.

Ok thanks…but where do I find Summary?

In my browser, upper right corner, left click on my (or your in this case) avatar icon, which will open a dropdown. Top row of the dropdown has 4 icons, far right of which looks like a pawn (labeled preferences if you hover over), click on it, which allows you to access your summary, or go straight to preferences in that dropdown.

This is in straightdope dark theme, but I believe will be similar/same in most other themes.