File associations in Win-10.

Under older versions of windows, if you opened the file associations menu, with each file, if you wanted to change the associations, one of the options was to browse until you located the executable (usually an .exe file) you wanted to associate with a given file type. In the latest version of Win-10, it is no longer specify the executable by browsing.

The particular file type I am looking at is .tex and it is associated with something called texworks, which is an editor I have never used. I would like to associate it with the editor I do use, but when I click on it, the only option I am given is that or go to the MS app store. Incidentally, my editor, which I have been using for 33 years is not installed by the MS installer, but by just putting it into a file. It does not show up in the list of apps at all.

Any way around this?

They make it annoying, but it is still there.

Right click the file,** Open With**, select Choose another app, check the Always use this app to open .tex files box, scroll to the bottom and select More apps, scroll to the bottom again and select Look for another app on this PC. Browse to the executable and it should then remember the association.

Here is what I did. From settings, I clicked on apps. Then Default apps, then Choose default apps by file type. Then I scrolled down to the .tex level and tried right clicking both the .tex icon and the texworks icon. Nothing. Then I clicked on the texworks icon and a little window opened giving the choice of texworks or an app from the store. I tried right clicking on everything in site to no effect.

There was no Open with choice nor the rest of what you said. The problem, as best as I can guess, is that the editor was not installed by the windows installer and presumably has no registry entry and is not on the list of all the “apps”. I just sent MS feedback saying that every upgrade of windows makes it harder and harder to use.

If you follow Number’s instructions rather that doing what you did, you’ll be able to associate the extension as they said. Hint: open a folder in the File Explorer that contains a file with the appropriate file extension.

If you right click the file and choose Properties, you can click Change [application to open it], and take it from there, to browse for the app in File Explorer which is presented when you click “Choose another application”. At least it works for me, with a file with .tex extension. Or am I misunderstaning the problem?

i may/mayn’t be addressing the specific issue you opened with.

keep in mind … if you were to ‘force’ notepad/wordpad to open the file by changing file-association … each specific *.tex file probably would display only the source-code equivalent … it will not display as the program was initially designed for. not only that … the *.tex extension serves more than one program [purportedly] … not only for latex files (; but also for texture-files extensible in another program … and datasheet-files extensible in yet another program.
*" LaTex TEX files are used in the fields of computer science electrical engineering and physics. TEX files can contain text, mathematical symbols, mathematical expressions and graphics. LaTex files can also have a LATEX file extension. The TEX file extension is also used for texture files and Idealist datasheet files. "*ref:
Computer Glossary, Computer Terms - Technology Definitions and Cheat Sheets from - The Tech Dictionary and IT Encyclopedia
How can I open a .tex file? - Stack Overflow

When I open a .tex file in texworks I get the file in an editor window on the left half of the screen, and an output preview window on the right half. If I force it to be opened in, say, Vim or Notepad++, I just get the file in the usual Vim or Notepad window. The file itself is a plain text file, which I assume the OP just wants to load up in his favourite text editor by default with a click.

The hint was what I needed. I didn’t understand that I was to right click on some random .tex file, but that was what did it. Sorry, I misunderstood, but thanks for the correction. I tried it and it worked just like Number said. I then tried it on another .tex file and it loaded in my editor. Which, just for the record, is called kedit and I have tuned it for 33 years to be a super editor for .tex files. Probably, had I done that with any other editor, I would now be wedded to that.