Firefox can't access gmail?

For two days now, Firefox won’t open Gmail for me. It shows:
“The connection to www.google.com was interrupted while the page was loading.”
The failing URL is a long one that begins
https://www.google.com/accounts/ServiceLogin?service=mail&passive=true&rm=false&continue=http%3A%2F%2Fmail.google.com%2Fmail%2F%3Fhl

Internet Explorer 7.0 accesses Gmail just as well as it ever did, so I am able to read my mail. Still, I wonder what’s going on. Do I have something misconfigured? I run Gmail in “Basic” mode, but not sure that matters: Firefox doesn’t even get to Gmail’s login page.

Edit: Oops. Moderator, please remove extra ‘x’ from thread title so I look less the idiot.

It’s always worked fine for me. Occasionally, something gets stuck in the cache or the DNS and I can’t connect, but that takes seconds to resolve. Have you tried just entering http://mail.google.com/ and seeing what happens?

Do you have any adblock - type extensions in place? If so, it might be worth trying again with those disabled. (long shot, but worth a try)

Normally I just enter “gmail.com” or click “Gmail” from the Google home page. Neither worked. Reading your post just now, I entered your suggested URL and it worked! I clicked Back and tried both of my usual methods; they both now worked correctly also. What’s changed? – I don’t know. Could entering your suggested URL have re-validated some cache entry?

Whatever it was, it’s just the tip of the iceberg on my list of questions of strange Windows/Internet behaviour. :smack:

Thanks for responding.

Problem is intermittent, has recurred, and, as I suspected, any distinction between the URL’s to get to Gmail seem to be irrelevant. I also have trouble accessing Google Maps sometimes. One constant seems to be that I’net Explorer succeeds when Firefox doesn’t.

I use a work-around for another problem which slows down my transfers, and may exacerbate Google problems.

The other problem might be an appropriate topic for a separate thread, but I’ll try to solicit advice in this thread. I use a Novatel Wireless Mobilink to connect, via antenna, to my provider. Worked well for several months but lately it dies. Recovery involves disconnecting modem and reinserting, clicking connect, usually getting an “in use” error message, detach/reinsert modem again, click connect again, it then finally reconnects! :smack: Not sure if problem is provider, modem or laptop virus but provider may be most likely as a neighbor has similar symptoms. (Contacted provider rep who suspected laptop virus.)

Anyway, I have a workaround for that problem: I keep a huge but useless upload running at all times! This may slow down useful Internet work, but the connection-dying problem seems to happen only when Internet is idling.

As you can see, I’ve mucho problems here, especially ignorance, so friendly useful advice is welcome! :smiley:

  1. Uninstall/reinstall firefox. Sounds like your installation is corrupted.

  2. Other symptoms sound like:
    a. 2 or more routers on the same connection. Routers act like Thunderdome: two routers enter, one router assigns DNS. If there are two or more, only one can be set as a “router,” the rest are assigned as “switches.”
    b. Dying router.

As a side note: whenever a neighbor has exactly the same problem connecting as you, and the isp doesn’t say there’s a hardware problem on your street, it’s very likely that neighbor is stealing internet from you.

Have you done a full reboot as opposed to hibernate / standby? This happens to me periodically, and a reboot solves the problem.

That won’t help much. Firefox stores its settings separate from it’s installation. Since you say it (temporarily) fixed the issue using a different URL, I’d first try clearing your cache, then clearing your cookies. If those don’t work, I’d try making a new Firefox profile.

Only after trying those would I suspect that Firefox itself needs reinstalling. But if you are not having problems with other sites, I’d find that unlikely.

BTW, you aren’t using Firefox 4, are you? It caches javascript, and that can mess up Google. Clearing your cache will fix it, but if its happening to regular users (and not just me who’s using a funky configuration), then it might be something the developers would want to check out before Ff4 is officially released. Even when the bug is in Gmail, people tend to think it must be in the browser.

Neighbor is about 4 miles away; we both get Internet signal from a radio transmitter roughly halfway between us. (Just 2 days ago, he reports that he gets one “signal bar” instead of the usual 4; I still get 4 and assume his new symptom is unrelated.)

Yes, we usually boot at least twice a day. (For one thing, I prefer Linux but boot Windows to access Internet. Yes, I could try to access Internet from Linux, but my daughter insists on Windows and I’d prefer to reduce the number of confusing variables not increase them.)

I’ll read those links but just did a “Clear (almost) all history” from Options->Privacy. It must have cleared much since I had to re-enter my SDMB password. (Actually, I needed a new password mailed as I apparently forgot/mistyped the old password; to access the new password I had to click I’net Explorer, as Firefox still couldn’t access Gmail today, despite the Clear (almost) All.)

My Firefox is 3.6.13.

BTW, there are some sites (Alternet, rarely NYTimes) where I’net Explorer fails with an error message, but which Firefox can read OK! :smack:

Flakey speed and other Internet provider issues may be part of the problem…

Then go for the profile fix, then. You just did the part where you clear you cookies and history.

There is another option I didn’t mention, but it seems a bit more likely now that you admit that Explorer also can’t visit some sites: you may need to scan for malware.

Thank you. I’ve never explicitly created a Firefox profile. Did it make one for me anyway?

I also suspect malware, wonder if a complete Windows re-install is best idea, but have been paranoid about losing data. I bought an external hard drive recently and am backing up, and soon may take the big plunge: “Reformat me!” I did have a Fujacks infestation some months ago, but am pretty sure it’s gone.

I run Avast! Free antivirus without any reports of malware. Any other free antivirus programs I should download? Doing Ctrl-Alt-Del --> Processes I see 40+ processes, many with names meaningless to me. Is there a straightforward way to compare these process names with names of known malware?

By any chance are you using Rogers as your ISP? If so, that’s the answer.

I, and apparently many other Rogers clients have had a similar problem recently. I spoke to their tech support people and they were honest in saying that they weren’t sure exactly what the problem was but noted that only some IP addresses seemed to be affected. I thought it was interesting that the rep said they expected to have everything working normally “in a few hours”. Ain’t that something? They don’t know what the problem is but expect it to be resolved shortly. Sure.

If that’s the case, it’s probably DNS poisoning. It’s like taking the phone book and changing people’s numbers. Your computer looks up a site, but gets the wrong IP number.

I believe that, if you host a DNS server with fake data close to another DNS server, the second DNS server may pick up the fake data. This happens because DNS servers self-propagate: if you register your site with one server, it will send it to every other server.

These types of things self-correct once the fake DNS server is taken offline, or perhaps if the server notices that only the bad DNS has the wrong entries. (At least, I hope there’s some way to automatically ignore malfunctioning DNS servers.) So likely the Roger’s people have never actually had to do anything to fix the problem.

There is one thing you can do, however. Use another DNS server that is less likely to be poisoned. Google has one at 8.8.8.8, and you can google OpenDNS for theirs. Also Google how to change your Secondary DNS for your operating system. It should be easy.