Firefox question-It ate my bookmarks!

So I’m happily zooming around the Internet, I got 5 windows open…when everything stops. I assume the computer is just getting a bit tired, so I close all of the windows and decided to slow things down a bit. I click on Firefox, and suddenly, it needs a new profile. I have no idea what this means, and it can’t use the old one somehow. I say “yes, new profile” (and my dog looks at me) and press the button. Now all of my hard-found bookmarks are gone! Can I get them back?

This is an error that I get on occasion too. Firefox hasn’t closed all the way, and there is still an instance running in the task list. What you need to do is close all open instances of Firefox and then open the task manager and end any other ‘firefox.exe’ that you have running. Then you need to delete the new profile that it created. The profiles should be in C:\Documents and Settings*username*\Application Data\Mozilla\Firefox\Profiles. Delete the newer folder and you should be good to go. It will have some name like random numbers and letters.default. If you are unsure which profile, look at the bookmarks.html file in the folders and see which one has your bookmarks. That’s the one you want to keep. After you do that, reopen Firefox and everything should be back.

If this works, then thank you! If not…thank you anyway! :smiley:

I had this bug pop up a while back, and wasn’t able to restore things. Good luck!

So *that’s *what happened?! That happened to me a few weeks back, and I couldn’t figure out how it was possible. My husband was cleaning temporary Internet files on his computer, then suddenly I lost my bookmarks. We couldn’t figure out how it was possible for him to have done that to my machine, but we were at a loss to explain it.

For some reason, I can’t find the file you mention, the C:\Documents and Settings\username\Application Data\Mozilla\Firefox\Profiles. Anywhere. Am I doing something wrong? Should I be looking elsewhere?

For the file I meant, not for help. :smack:

I should have posted this as well:

It has a little more info on where to find the profiles.

It may be in a different location than I said, so take a look at the link and see if you can find it where it’s listed.

Ensure you can see hidden files. Open a folder, go tools----folder options----view (2nd tab)—show hidden files. The application data step is a hidden folder.

Ok, deep breath, just to idiot-proof (for me, not you) this…I’ve found two profile folders. I’m supposed to delete the one that doesn’t have my bookmarks and everything will be as it was?

Yes, it should be.

Aha! While I wouldn’t like to say that I am glad to hear you have all had this problem …well… it IS sort of comforting to know that it is not just me. This has happened to me twice now, and each time I worried that I had done something very stupid and thought I was going mad.

Fingers crossed I remember this thread if Firefox looks like doing mad stuff again. (Still not going back to IE though. :slight_smile: )


I did this: In profiles.ini, locate the entry for the profile you’ve just moved. Change the Path= line to the new location.
Change IsRelative=1 to IsRelative=0.
Save profiles.ini and restart Firefox.
Still not working…instead, it creates a whole new profile with no bookmarks. I found them, I just can’t get the computer to see them and use them…am I missing a step? Grrrr…I’m getting just a little annoyed… :mad: :mad: Oh, and I can’t use the"default" because it’s in use…huh?

For the default in use, check task manager–processes–firefox.exe, kill it, don’t worry about the scary windows warning.

If you know have more then one profile under " C:\Documents and Settings\username\Application Data\Mozilla\Firefox\Profiles" but know which one has the bookmarks you want go into that profile. There should be 2 files, one called "bookmarks.bak’ and one called ‘bookmarks.html’. Copy these, put them on your desktop. If all you want is the bookmarks, delete every profile. Launch firefox to create only one profile. Close it. Make sure its closed via task manager. Then copy the bookmarks back into the profile. Open firefox. You should have your bookmarks back.

In the future, if firefox says it a profile is in use don’t create a new one, just close it using taskmanager–processes. Incidentally this is also a much faster way to close all non-responding programs. However, if you are an internet explorer user you must remember ‘explorer.exe’ and ‘iexplorer.exe’ are 2 different things. Kill the latter ONLY!

BOOYA! It worked! Somehow! Now I’ll be terrified of my computer but I don’t care!

Queuing, I could kiss you! But I won’t since that would be weird! But accept a hug and a solid “I owe you” instead. You have given this Doper a reason to post idiotic ideas in the Cafe again!

You are welcome, happy to be of service. After some further reading, apparently this is a known issue of Firefox, and according to another thread on this board, is not being fixed in the latest release.