Firefox - Tabbed Browser Question

Firefox just started doing this to me last night.

When I right-click to ‘Open link in new tab’ the new page insists on opening on the top of the current page, rather than below, the way it has been since I started using the browser. This is making me nuts, since the beauty (to me) of tabbed browsing is the ability to open new pages without interrupting the flow of the page I’m on. Like opening a dozon or so general questions while reading down the list.

So what’d I do? Have I accidentally clicked or unclicked a preference somewhere?

In Preferences -> Advanced -> Browsing you should see an option “Select new tabs opened for links.” Make sure that’s off.


Many thanks. I have no idea how that got checked.

Glad to know Queens is in the house.

A (possibly) even more convenient way: Firefox will open a tab in the “background” if you simply shift+ctrl+click the link.

You don’t even need to press Shift. Ctrl+clicking will open the link in a background tab.

And as I just discovered tonight, if your mouse has a clickable scroll wheel (one that can be clicked like a regular mouse button), using that to click on the link will open it in the background. I defy anyone to find anything easier than that :wink:

The “Select new tabs opened for links” option controls all of these shortcuts.

middle click = whatever the “Select new tabs opened for links” option says
CTRL+left click = same as middle click
SHIFT+CTRL+left click = the opposite of what the option says

I set an extra button on my mouse as a control key, so I just hold it down while left-clicking the link. It’s harder, for me at least, to click the mouse wheel. I just wish I could set a mouse button to control-click on its own, but the mouse software doesn’t seem to support that.

I need to bump this, since after downloading the latest FireFox, I find I again have the same problem as I mentioned in my original post (tabs opening in the foreground) and none of the previous posted fixes apply.

I’ve looked through Tools and Options; am I missing something? Again I plead to the teemings…

It’s called “Select new tabs opened from links” - make sure it’s off.

If that doesn’t fix things, check your list of extensions. I used to use the Tab Browser extension to fix things the way I liked them, but a few versions ago Firefox started to do things right, and TabBrowser was just in the way, so it’s been uninstalled.

There are other extensions that modify tab behaviour, of course. If it’s still a problem, post a list and someone might be able to help.

That did it! Thank you!

Because it’s a similar topic I’ll try to ask it here-

Can you set the ctrl-tab options for firefox tabs to work the way it does in windows? (i.e.- be able to switch between the last open tabs without having to scroll through them all as is the default?)


If you get the Tab Mix Plus extension, you can customize exactly what Ctrl-Tab does.

Beautiful! That exactly what I was looking for.