Game fans: It's Grow Civilization!

From the makers of Grow, Grow 2, Grow Cube, and Grow RPG! Turn your little island into a thriving metropolis! Or whatever it’d be in the weird world of Grow!

I can never quite figure them out. They look cool, though.

Think I figured out the proper ending, but it keeps freezing on me after I push the last button. Could someone test out this combination and tell me at least if it plays all the way through for them?

Bolt, log, pick ax, peace sign, red tower, battery, computer chip, chemistry tube.

I’ve got

Bolt, Pickaxe, Logs, Smokestack, Steering Wheel, Battery, Computer Chip, Beaker

That worked for me.

Everything is still moving for me but it won’t tell me how I leveled out, so there does seem to be a flaw in that configuration.
I played with it a few times then found the cheat online. :stuck_out_tongue:

It froze on me too. Must be a bug.

Brilliant! Thanks for the answer, folks. :slight_smile:

I did something different (too sleepy to do a spoiler box) and maxed out. Cute game, though. Perhaps it works no matter the combo?

Uh, no. If you do poorly, you get booed. It’s bad when the house collapses and the little woman says no.

I can’t remember what I did, but I got the same ending as you get with Team of Scientist’s combination, but it tallied the scores before the end animation and all Level Ups played out, so it said everything was maxed except the mining pick. Weird. I’ll post it when I figure out what I did again.

Just missed the edit window. The combination was Bolt, Mining pick, Logs, Steering Wheel, Battery, Smokestack, Flask, Computer chip. Still gets the full ending, complete with the picnicking and the animals, but the scores tally up right before the picnic happens. As an added bonus, the flasks turn into a weird mountain thing with a floating green ball, and it says “UFO Up!” Like I said, weird.

How did you get him rejected by the woman?

I’ve found that if you don’t build the incinerator until the end, they will dump their trash by the river, causing both the man and woman to turn dark gray. The man then cuts down all the trees (so then when the volcano erupts, the lava flows all the down to the road, ruining it) then he connects a laptop to the computer and uploads a virus, destroying it.

You level up Environmental Engineering so that the fence blocks the lake. So the guy can’t create the river to grow the flowers, he tries with her anyway, and she shoots him down.

Poor little dude.

ah they added more games since i last visited! this is cute, so is Grow RPG ! watching the little guy adventure his way around at the end is a nice twist.

Chronon looks interesting too. i spoiled it for myself when i googled for some hints as to how it works :smack: if anyone else wants to try it without cheating i’ll drop hints here if you wish.

I did that and just got a loser ending with the mining pick at level 3, and the computer chip at level 1. No “UFO up” or anything.

I did already figure it out and got the good ending before, and I am still left wondering…what the FUCK is that weird dog thing in the volcano?!

Weird, I just tried again and it’s doing that for me now too. I wonder if activated a bug somewhere in there in a previous try to get that ending before. I definitely repeated that sequence several times, and got the pseudo-real ending each time.

OK… I’ve been trying to get the striped thing on the clock (at the part where “7” should be) off the clock the same way I got the egg and the key. Is that the right thing to do? If so, how do I do it?

yes, it is the same way. i’ll split the spoilers into different stages, starting from hints to the answer at the last.

if you got the egg the clock would be at one o’clock. that’s 6 hours from the candle. (striped thing) [/spoiler] you can get 6 hours in two steps. 5 hour 10 mins and 50 mins. [spoiler] 9:45 to 14:55 and 18:10 to 19:00.