Have links to YouTube been disabled?

I just tried posting a couple of YouTube links in

and got the message

An error occurred: Sorry, you can’t embed media items in a post.

What’s going on?

Same error when I tried.
Win10, Opera.

Looks fine to me:

Admittedly I haven’t tried making a post with a YouTube link to see if I get the error msg, but the resulting post itself seems to work. I clicked through and it plays.

I was trying to add new bagpipe videos to that thread but they wouldn’t post. Got that message instead, same when I tried to add the same links to this thread.

Win 10, Chrome

Well I don’t know what you did to finally make the post linked to in the OP, but yes I get the error message too. And unlike you, I don’t end up with a post that actually goes through nevertheless.

I see … posting on a line by itself doesn’t work but this does…Flowers of the Forest - YouTube

Oh, duh, the one that’s working was posted by River_Hippie, not by you the OP, Skywatcher.

You were trying to add to that post.

Yes, something has changed. I tried to post a link to a YouTube video and it appeared fine in the preview screen, but won’t post, unless (as noted above) it’s on the same line as other stuff so it doesn’t try to create a OneBox: Massed Pipes & Drums parade through Deeside town to start the Ballater Highland Games 2018 - YouTube

ETA: Test to see if OneBox itself is broken … (No it’s fine, it’s just YouTube)


But I couldn’t edit that after posting it with the (working) Youtube link. So that’s probably where the error lies.

I couldn’t post a YouTube link at all (“An error occurred: Sorry, you can’t embed media items in a post.”). Except as I said, when it’s inline with other stuff so that it doesn’t try to build a Onebox.

Something is bust.

never mind

Let’s see…

I can post one ^, but if I try to edit it I get the error message.

Let’s try it with Chrome instead of Firefox …


An error occurred: Sorry, you can’t embed media items in a post

I’ve got that error message a lot ever since the Great Migration of 2020.

I’ve never been able to figure it out. Sometimes I can post images and YouTubes and tweets, and sometimes I get that error message.

No rhyme or reason to it, but then, I’m the techno-peasant in the room.

To me that message sounds like it thinks that you’re trying to upload media such as a picture or video clip directly to the board, which is not allowed by board policy. It’s strange to be getting it for just a link, and stranger still that it cheerfully creates a Onebox for image links but not for video links, and even stranger that video links work for some users but not others. YouTube links were definitely working for me until quite recently, like no more than a week ago or so.

As @wolfpup says just above, this is mystifying.

I last posted a visible playable youtube successfully on the 28th. But I failed upthread an hour ago.

Upthread I also tried posting a broken link which posted but was of course useless. Then I tried editing it to be an un-broken link which failed to save.

And this whole thread really belongs in Site Feedback which is about tech issues. ATMB is about management issues. I’ll report it for a move.

Moved from ATMB to Site Feedback.

As you and most of us know, Discourse is updated fairly frequently, and this is almost certainly the result of one of those updates.

And please, anyone, ask me how I know this. :angry: I know it because I’ve had to update my desktop browser twice, and my tablet browser at least three times. In the case of the tablet, one update was for Discourse to keep working, and the other two updates were to fix things on other websites that the first update broke. Personally I’m dearly enamoured of the concept that when things work, they should be left the hell alone, but apparently not everyone shares this opinion.