How can I completely uninstall a stubborn Oracle?

I’m having issues with memory on one of my work computers, and Oracle has been chosen as a space-hog that I can do without on this particular machine. The thing is- nothing I can do with completely get rid of it!

Now here’s where there night be a problem- I tried to install Oracle 9i where 8i already existed, so that might be causing conflicts, but here’s waht I’ve tried already:

Uninstalling via the 9i disk.
" " " 8i disk.
Using the Add/Remove software utility in Windows 2000.
Deleting/moving to another part of the hard drive (D:) the Oracle folder directly.
What I’ve gotten for results:
Oracle, in both the disk cases, uninstalls and says everything’s dandy- only the Oracle folder is still sitting on my C: drive taking up a ton of space.

The Add/Remove utility runs through the removal process without a problem, but that Oracle folder is still there upon completion. Also, Oracle no longer appears as a choice of current programs able to be removed on the utility window.

Deleting the folder shows a sharing violation of omtsreco.exe
and stops deletion or moving. This exe is impossible to stop directly from the Win Task Manager.

Any suggestions would be appreciated, and thanks in advance,


Unfortunately your mistake was installing Oracle 9 in the same folder as 8. It should have warned you about needing different oracle_home directories for each version and not let you do that.

I’ve found the same problems with Oracle’s windows installer products so at least you’re in good company. What you’ll need to do is delete the content of the oracle folder a subfolder at a time to get around the sharing violation.

See if you can identify the process using that file and kill it then deleting the file. BTW, what version of Windows?

You might also need to go to the registry and delete some of the Oracle entries. There should be documentation on the Oracle web site on completely eradicating all traces of Oracle.

It’s Windows 2000- I’ve found the file that’s causing the unkillable process to run, but it won’t let me delete it straight away.

Yes, Oracle is tenacious. I’ve found that I need to boot from a floppy, and at the DOS prompt go to the hard drive on which it was installed, and delete it from there. If you are using an NTFS system, though, you need to boot with a DOS prompt that recognizes NTFS. Check Google for your nearest friendly software vendor.

I then reboot in Windows, and manually go through the registry (after making a back up, to be safe), and remove all of the references to Oracle.

Seems to work OK.

Thanks, Level3, and welcome to the boards!

Grrr… I really hate Oracle.

Don’t hate Oracle, hate Windows. Both are lead by evil megalomaniacs but one knows how to have fun.

Padeye, the Oracle and now Teradata DBA

After you do the “official” delete, get rid of everything you can under the Oracle directories (which, as you know, will not be everything that is there). Then go to Control Panel/Services and disable anything that has the word Oracle in it. Then bring up the Registry editor and search for “oracle” and delete anything that it finds. Then reboot and do it all again (there shouldn’t be anything in the Registry, but you never know)–that should clean the whole thing out.

As you can see, I’ve had the same problem myself. Sheesh.

Thanks ** NoCoolUserName** - that totally worked!

I am now 100% Oracle free!