I Can't Upload A Picture

And I think I know how. I will try it once again. Then, I will edit this thread to just include the link.

BTW, the picture is my two cats in a romantic embrace. I love the picture, because I think it shows animals have all the human emotions too. Both cats were fixed at the time oddly. (I know. I digress.)

Here goes:

EDIT: Nope, didn’t work.

Here is the link, so you know what I am talking about:

http://www.picturetrail.com/sfx/album/view/1000279/12842762

agreed … noticed it start failing last week? tried the beginning of this week … and, no cigar … nothing. i just figured admin had gotten tired of seeing images plastered all over posts. might just be still going through growing pains. :smiley:

Still works though maybe some sources or the formatting of the URL disables it.

Here’s the OP’s picture:

I right-clicked on the image, selected “Open image in new tab,” and posted a link to that (which is just the jpg).

@Thudlow_Boink I hope it’s just me. But I see no picture there at all. Just a broken link :slight_smile: .

I think I figured it out. If the picture source is not a secure connection, the picture won’t appear here.
I tried a bunch of random photos in preview and that seems to be the common factor.

Just to make things clear from a terminology point, none of this is uploading. What you’re doing is embedding an image that is hosted elsewhere. Except for profile pictures, the SDMB doesn’t allow uploading pictures.

Well, dang. It’s showing up for me on the computer from which I originally posted, but not when I check the thread on my tablet.

Another way to do it; right-click on the image in the webpage in the OP, select Copy image address and paste that URL all by itself on a line.

Update: Picture does show up on a different computer (using Chrome); does not show up on my phone (also Chrome).

Bottom line: images will appear as images if all the following are true:

  1. The url is on a line by itself and was NOT added to the post using the add url button. Instead just paste the link into the post directly.

  2. The url ends in an extension that’s associated with images, such as .png, .jpg., .gif

  3. The site the url is hosted on doesn’t do a bunch of fancy fiddling with what data they return versus what the url purports to refer to.

The poster can always control #1. The poster may or may not be able to control #2 & 3 depending on which site the image is hosted on and how they found it.

Late add; too much editing after posting too soon. The OP’s url as posted fails both my items #1 & #2.

By posting the link correctly to fix item #1 I get this:

On my Chrome on Win10 I see the above url as a boxed item talking about PictureTrail with a clickable link, but not showing the image. Clicking that link takes me to a whole web page that has that image on it, plus lots of words, menus, clickable buttons, and other stuff.

From that web page I can capture the url of the picture itself. I did that by right-clicking on the picture and choosing “copy as image address”.
Different browsers will call this by different terms. Once I have copied the image address I pasted it onto the line below this paragraph. Which fixes both #1 & #2 on my list.

At least for me, that now shows the two cats. Which means that that particular website doesn’t f*** with my #3.

I’m seeing the same results with your post that I did with my own: the image shows up on my desktop (Win10, Chrome) but not on my phone.

@ Thudlow just above …

An unfortunate side effect of Discourse being so CSS-driven is that stuff looks different under different themes. You can only know how your post looks under the theme you’re using.

Discourse and its themes are also device-aware = phone vs tablet vs PC vs ???. So you can only know how your post looks on the device(s) you’re willing / able to test it on.

Another issue is that websites themselves are free to deliver different content to phones than to tablets than to PCs. or to different brands of browsers. Which is to say my #3 is a moving target depending on which device is doing the viewing.

While composing this post on my PC I tried this page on my phone, a Samsung Android using Chrome. The 2-cats pic does display on my post and on yours.

At least some phones have a browser setting to enable or disable inline image downloading. That may be your issue.

Excellent and correct answers here, but the http versus https issue is probably the specific reason (as also noted above).

The web is rapidly headed to a https-only (secure) view, which is definitely a good thing, so if you are seeing http (or the lack of a :lock: icon next to the address bar, kinda the same thing) it would be wise to avoid those types of sites in the future as they are

  • already pretty far behind the curve on https adoption

  • can be tampered with pretty much at will by any middlemen

  • indicative of a site or service that is probably in a state of decomposition without active maintenance and will be shuttered sooner rather than later

Mixing http and https is considered dangerous to the point that it’ll be actively blocked by browsers in the very near future if it isn’t already.

That works - thanks!!

testing…

My Annie

Red eyes are the sure sign of a cat that will eat your corpse (or almost-corpse) if you ever give it half a chance. Don’t stumble in the shower. :wink:

Experimenting with uploading pic (from website).

Imgur