iPhone - now with MMS!

AT&T rolled out their long-awaited carrier update yesterday, September 25, which allows U.S. iPhone users to send and receive multimedia messages.

You need OS 3.1 to do this, so it’s available only to owners of the 3G and 3GS iPhones. 3GS owners have the ability to send and receive video messages in addition to picture messages and voice memos.

It was very easy and painless for me to set up. The first thing to make sure of is that you already have a text plan from AT&T.

  1. Open iTunes and connect your iPhone to your PC.
  2. Go to your iPhone summary and choose “Check for updates.”
  3. It will tell you a carrier settings update is available. Choose “Download and install.” It is a small download. It only took about 10 seconds and didn’t overwrite the OS.
  4. Disconnect your iPhone. Power it off, then back on.
  5. Go to your settings. Choose Messages. Make sure MMS Messaging is on.

You can now send photos and voice messages from your 3G phone and additionally, send videos from your 3GS.

Congratulations! Glad AT&T got their act together.

Thanks, iPhone! Oh BTW, 1997 called and they want their features back.

I just sent some messages to people with me making this face: :eek:

“Now with…”? Oh, hah, you must be living in America. Heh.

Actually, you can get the carrier update without updating to 3.1, in case you have the 3GS and still want to jailbreak (the original iPhone and 3G can be jailbroken with 3.1, but not yet the 3GS.)

It’s a more complicated process, but basically you have to download the carrier update yourself, change a setting in iTunes using the command line so that you can manually update the carrier settings, and then go into iTunes and do just that and navigate to where you saved the downloaded carrier settings.

Yes. MMS was enabled on my Canadian 3G as soon as the carrier rolled out OS 3.0. There was a carrier update file as well as the new OS.

I don’t really ever use MMS, but I have had it for a few days now. I’m glad my phone has caught up to the free phone I got from AT&T 5 years ago though.