Keyboard command # stopped working

I noticed this for the first time just a few days ago.

The keyboard # command pops up a little dialog box, in which you can enter a desired post number, and it jumps directly to that post. This has stopped working. Now, no matter what post number you enter, it takes you to the first post in the thread.

More precisely: It takes you to the desire post, but only for a brief moment. Then the page appears to re-load itself, but leaves you at the top of the thread.

I’m not seeing this on Windows and SDMB Light theme. Which OS and theme are you using?

I am using Straight Dope Light theme. Computer is an old-ish MacBook Pro, browser is an old-ish Firefox. This is the environment I’ve been using for a long long time. Nothing has changed on my end that I can think of.

I know that # used to work because I’ve used it. But it doesn’t work for me now.

Now wait a minute. (As I type this, I see you’re in the midst of typing a reply too.) I just noticed this:

If I type # then enter a post number then click on the OK button, it works as expected. But if I enter a post number then press the Enter key, it fails as described above. But that is exactly how I’ve used the # command previously, which used to work. So something has changed.

An old browser is the most likely cause. Discourse keeps being updated, and if your browser is not reasonably up to date you will start to have problems.

It just seems like a odd quirky thing to suddenly have problems with. Why would a Discourse update mess with some detail like that? I haven’t noticed a similar problem with other dialog boxes (although to be sure, one doesn’t deal with dialog boxes much in Discourse), and I haven’t seen other problems all of a sudden.

It probably comes down to updated versions of JavaScript, and which version of JavaScript your browser supports.

You could try downloading the latest version of any browser and see if you have the same problem with it.

I can’t reproduce this problem at the moment. Can you @Senegoid?

Yikes. That was almost 2 months ago I was seeing this. IIRC, I played with a little bit back then and, IIRC, I was getting inconsistent results that I never quite figured out. I’ll try this again sometime in the Near Foreseeable Future (perhaps later this evening) and I’ll let you know what I find. Quite probably, GreenWyvern is right, that it probably depends on whatever version of something-or-other I’m running here.

Okay, I played around with this some more. I can’t get consistent results, but this is what I am seeing:

  • When I type # and a post number, sometimes it takes me back to post #1, and sometimes (more often, I think) it just takes me back to the same post I was looking at before.

  • This is only inconsistently repeatable. If I repeat the attempt, I usually get the same result, but not always.

  • It seems to happen more-or-less repeatably in some threads, but not at all in other threads. I tried looking at several threads in several categories. In some of these threads, I could not get the problem to happen at all. In others, it happens.

  • In some cases, it took me to the next-unread post, but I think I was probably already looking at that post. Now, I think it doesn’t matter what posts I have or haven’t already read.

ETA: This thread itself is one in which I am trying this, and seeing some of these anomalies.

ETA2: It looks like the most common result is that it just puts me back on the post I was previously looking at.

ETA3: Note the description in the OP: It actually takes me to the desired post, but only momentarily. Then the screen refreshes, but positioning to the wrong post.

I tried this to see what happened.

I entered at post 8 (having previously read 1 to 7). I went to jump to post 7. It loaded, then went back to post 10. I clicked on the browser back button and it took me back to post 7.

I tried again, this time to post 3. The same thing hapopened; post 3 loaded then it jumped back to post 10, and clikcling the browser back button took me to post3.

At least that is a workaround involving one extra click.

Windows 10, Firefox. Everything up to date AFAIK.

I’ve never used the # command before now, but I’m seeing the apparent malfunction exactly as described.

type post number, press enter: goes to that post for a moment, then reloads and goes the the initial post. Go back a page to see the requested post.

type post number, click on “OK”: works.

Here’s another workaround. Type the post number. Press tab twice (this moves the focus to the “OK” button). Now press enter. Works.

Back button is not part of the discussion at the moment @MHaye … interesting repro @rowrrbazzle … are you still seeing this? I can’t repro any problems in Chrome.

  • I type #, 2, enter and I land on the second post in this topic.

  • I type #, 8, enter and I land on the eighth post in this topic.

Is it Firefox specific?

Unknown. Firefox is the only browser I have here.

The back button work-around is at least worth mentioning so we know of a work-around. I think the tab-tab workaround looks easier, though, and perhaps more reliable. One never knows exactly what the back button is going to do.

This is Web Programming. Write once, debug everywhere.

Could be. I finally tried this in Chrome and it works perfectly.

There is one thing I noticed. With Firefox, the “ok” button is nicely contoured and colored a light blue. When I tab twice, “ok” changes to a noticeably darker blue color (indicating focus).

On Chrome, “ok” is a plain, flat, square blue button. If I tab twice, moving the focus, “ok” becomes an almost imperceptibly darker blue.

Apparently Firefox does handle this differently.

I just tried this in Firefox and it does work #, then a number, then enter, but it forces a full topic reload which is … odd. I’ll take this back to our team.

One thing I noticed if you use the mouse and don’t press enter you avoid the problem in Firefox. So that’s the workaround for now. Skip that last step, use the mouse instead. Sorry.

Thanks heaps for the bug report! We have it fixed (and a fix is deployed here already)

Just re-tested on Firefox and it is looking good here!

Thanks, @samsaffron ! It’s really weird how something like that would behave differently with different browsers.

Web programming: Write once, debug everywhere!

Did you happen to note the other recent thread in which I mentioned that dragging-and-dropping text from somewhere into a Discourse text box also doesn’t work? See here, including a scenario where it would be helpful: