Quote and formatting functions have suddenly broken

As of about an hour ago, these functions have suddenly gone wonky. [Started happening around noon EDT, June 14.] I can only quote by highlighting text, then pressing the “Quote” popup. Once I’m in the Reply box, hitting the balloon for a full quote does nothing. Partial quotes via the “Quote” popup don’t work either. Neither the bolding nor italic formatting functions work – they just move the highlighting several characters over. Emoticons don’t work either – they can’t be inserted.

For reference, I’m using the Straight Dope Light theme but it’s not theme dependent – same problem with Sam’s Simple. Browser is Firefox. Tried it on a different computer with a newer version of Firefox – same result.

Testing Bold
:laughing: :stuck_out_tongue: :face_with_hand_over_mouth:

Everything looks OK. Chrome in Discourse Classic

They work for me. Also using Firefox. I am behind on updates though, so I’ll install the latest and try again.

Still works in version 101.0.1. :innocent:

I’ve never seen that constellation of symptoms before. My best guess is that you have something running on both machines that is causing the hiccup. Have you installed any new software recently? Changed any system settings? Added any new extensions?

Thanks to @What_Exit , @naita, and @GreysonCarlisle for the replies. I am just trying this in Chrome – testing testing and it works fine :slightly_smiling_face:

No, I absolutely did not change anything, and there is nothing new or unusual running. I suspect what happened was a Discourse update and both my versions of Firefox are old. I just checked and the one on the main computer is 80.0.1. I suspect an update will probably fix it. Will try on my spare laptop first and see what happens.

Ah, yes, that’s probably it. Good luck!

I just checked, the SDMB’s Discourse was updated 3 hours ago so that checks out as the most likely answer.

Yay!! I just upgraded to the latest version, and all is well again! I must say, those symptoms were really strange!

Part of the problem is that I had out-clevered myself. Getting tired of constant Firefox update demands, I had long ago disabled updates altogether via the “policies.json” administrator control file. So now I had to remember how to reset that!

Thanks, all! :slightly_smiling_face:

Sounds like my issue too (I noticed due to sudden inability to spoiler/hide details in the post menu). Ah, well - Netflix stopped working for me as well a little while ago.

Unfortunately, you can’t update past Firefox 78ESR on OS X 10.11 (El Capitan), and you can’t update past OS X 10.11 on a mid-2009 Macbook Pro, so I may have to start thinking about how to put Linux on this laptop.

Thanks for checking for the Discourse update, @What_Exit.

We’re not done with this yet! I’m having bizarre problems too, some of which resemble the symptoms described in posts above.

The “Reply” button (the one at the bottom of a post) doesn’t work. I first noticed it a while ago today. I closed my browser, re-opened it, and cleared out cache, cookies, and everything. That didn’t fix anything.

The main symptom I’m seeing: “Reply” button opens an edit box. Clicking on the “Insert Quote” button (the “speech bubble” icon) causes some strange blinkings, but the post being quoted doesn’t show up there.

Cutting-and-pasting text from elsewhere into this edit window has strange quirks too: If the copied text includes any html formatting, then no part of the copied text can be pasted into this window. (I just tried this again right now, and it isn’t working.)

It cannot have anything to do with browser updates, I don’t think. I am using an archaic version of Firefox (78.15.0) that hasn’t been updated since the French Revolution, and it worked fine yesterday but not today.

ETA: This is Web Programming: Write Once, Debug Everywhere!

Why would you think that, when a Firefox update solved my problem on both computers that had the issue?

Using an ancient browser is probably the problem. The software of the message board updated today and appears to no longer be compatible with very old versions of Firefox.

Please try another browser or device.

Okay, maybe I mid-read? I thought you said updating didn’t have any effect.

Well that sucks to the 7th level of hell. I can’t imagine why an update would break older versions in this way, that have worked fine all along. This is almost certainly a bug that should be, and probably can be fixed. I don’t have any other device at my fingertips, unless I hie myself out the the library and try it there.

I am using an older Macbook computer, that I don’t think can be updated any more. What, I should go out and buy a new computer now?

I don’t write or fix the code, I’m just reporting what happened. We don’t know when updates happen unless we check an admin panel display. That is what I did earlier when this thread was started.

I doubt you need a new computer, but maybe a different browser that will stay up to date on an older MacBook. Firefox is sadly falling to the wayside as far as browsers go. Good question for the Mac users on the board. I’m guessing there is a Chromium version or Opera that does stay up to date.

Don’t all Macs have Safari loaded? Can you use that to check?

Safari on my machine is just as outdated, if not more so, and cannot even open this site. It says “Cannot open a secure connection” or something to that effect. I think that means this Safari is too old to understand the current encryption method.

The kind of bugs being described in this thread just don’t sound like the kind of bugs that should arise when updating a Javascript app. What were they trying to improve with these modifications? New versions are supposed to be improvements, not break things.

Again, please check with other Mac users for a Chromium browser that might work or maybe try Opera. (or maybe something I’m not aware of)

All I can say as far as the browser problem goes, is there is a point where “archaic” are no longer supported. I don’t know if that is the case here or not. I’m not a developer for Discourse. Just a Mod.

We have a lot of savvy Mac users on the SDMB, there is probably a better and safer browser to use than an out of date browser.

As a retired IT guy I can tell you, you don’t really want to use a browser more than 6 months out of date and it is especially dangerous to use one over a year out of date. I would equate to using a leaky bucket.

Meanwhile, the Developers will probably address the issue if it is a bug on their side. But last time it took a few days to resolve as I recall.

I gave the newest and latest Chrome a shot (on my MacBook); it thinks that boards.straightdope.com has an invalid certificate and is not a secure connection. Firefox, OTOH, is just fine with it.

I’m guessing that Chrome may be looking to the OS for its secure connection support, but OS X 10.11 is a little too old for the kind of connection it’s trying to make. Firefox may have its own TLS support built-in. Again, this is just a guess.

I should mention that the Firefox 78 ESR (extended support release) channel for OS X 10.11 was up to date security-wise through last October, but at 8 months old it’s getting a bit long in the tooth.

All of which is to say, @Senegoid, that I hear you and I’m similarly bummed for a similar reason, but it looks like our computers have hit the support wall, at least as far as Apple (and hence Mozilla, and hence Discourse) is concerned.

Every time this kind of thing happens, I am reminded of that joke page about what would happen if Microsoft built cars.