My WiFi adapter stopped working after I updated an app. It now says "Code 10" and won't work. Any idea how to fix this?

TLDR: I updated my IPVanish VPN to its latest version and now my WiFi adapter won’t work even if I uninstall IPVanish.

I use a VPN for private internet surfing. I’ve been on IPVanish for about 3 years or so and it has been excellent. Yesterday, it updated its application and now my adapter will no longer work. It sees no networks and when I open up the device manager, it says “The device can not start - Code 10”.

I actually had the “Kill Switch” active when I updated the IPVanish application and was kind of concerned that it would disconnect from the application and somehow leave the kill switch active. However, I do have internet through my ethernet cable.

I have updated the drivers to the adapter and I uninstalled it and reinstalled it using Device Manager. No change.

I also reset my computer a number of times and even updated Windows 10 fully.

I will add something additional: I can only connect to “OpenVPN” even on ethernet now. I can no longer connect to “IKEv2”, which is what I used to connect to on IpVanish. This is the case using ethernet cable as well.

Note: If I can get my Wifi Adapter working again, that is what this thread is about. The IPVanish issues seem to be something they would have to resolve. Please help me get my WiFi adapter back up and running.

Windows 10
Intel Wireless-AC 9560 160Mhz

I…am considering refreshing my entire PC back to its original state, but I would like to save that as an absolute last resort.

Note: We discourage too much discussion of VPN’s here so I’d like to focus on the adapter and how to get it back up. I included relevant data about the VPN since it is what triggered the problem.

Googling that model wireless adapter and “code 10” results in this troubleshooting page from Intel. Try what’s suggested there.

Thank you, I have done so and it did not make a difference.

The real mystery is how updating a VPN program could:

  • make my network adapter no longer work even if the VPN app is uninstalled entirely
  • stop even ethernet from being able to connect to IKEv2, L2TP, SSTP, or PPTP on the app itself. Only “OpenVPN” will connect even on ethernet now.

It’s a real mystery. IPVanish support did write back and said they only see an issue with my adapter, so I wrote them back to tell them about the weird connecting errors I’m seeing.

I did buy an extended warranty from Amazon that I could try to process if everything fails. I’d rather do a full refresh of everything, even deleting all my files and setting the computer back to brand new. I’m not even sure how to do that. My computer has no disk drive.

You may have tried this, but…
In device manager, open the "network adapters’ section and right-click ont he wireless adapter, select “uninstall de3vice”.
Then reboot, windows will detect the “new device” and set it up as if from new.

Some VPN software can be set to stop all traffic except that going through the VPN virtual adapter. Many really secure systems do this e.g. large corporates where they want to ensure the device always goes via their controlled environment. Maybe you have fallen-foul of a driver that does this…

Obviously this comment won’t help you now, but in the future you should be using something like Macrium Reflect Free:

and schedule it to run every night.

So when you had your problem you would simply re-install a previous backup.

PS. Do you use System Restore? If you have Restore Points that may work:

https://support.microsoft.com/en-us/windows/use-system-restore-a5ae3ed9-07c4-fd56-45ee-096777ecd14e

I have been trying, but every time I use it(I have a restore point from June 29), it finishes, but says “We could not complete the restore. It may be your antivirus”.

I shut off my antivirus(Avira) and it still will not complete it successfully.

Update:

I bought a new adapter from Amazon. It’s the original part as far as I can tell. I got it off Lenovo’s site for the computer and it is the recommended part. I actually took it to a computer repair place since I don’t know how to swap it and asked them to check for a software/driver type issue or conflict.

They saw nothing and installed the new adapter for me. It worked perfectly. I guess the old adapter just broke…right at the EXACT second I updated my VPN application.

:man_shrugging:

It cost me $13 for the adapter I paid $45 for them to install it. Seems reasonable to me. I have no idea how it broke at the same time I updated an app, but there we are.

And, to no surprise to me, they also offered me to pay $100 for a virus/spyware cleanup that apparently it needed. No, I didn’t take it. That is the bread-and-butter of computer repair places since they just run a spyware/virus checker and charge $100 for almost nothing.

I turned them down.

:laughing:

Anyway, all fixed and thanks for the suggestions. It was the part!