Netscape won't open - anyone else had this problem?

My internet bank now requires Netscape 7+ or Internet Explorer 5+. I’d rather chew glass than install Internet Explorer, and since I’ve used Netscape 4.x for my internet banking up until now I thought I’d just get the new version and be done with it.

I’ve installed it twice, and both times it just won’t open. When I run the exe file, nothing happens. Absolutely nothing. No process starts, nothing. No hourglass, nothing. I’m being extra clear here because I’ve worked tech support and know that people are quite able to say “nothing happens” when a big red blinking cartwheeling popup shows up yelling in a Scottish accent. Trust me, nothing happens.

I fulfill the system requirements and am running Windows 98. Does anyone know anything helpful?

I’ve had some issues getting started with newer versions of Netscape.

IIRC, I downloaded a self-extracting archive, which revealed the install program, which then looked at my system and downloaded the files I needed, which took hours on my poor little dial-up connection.

Where are you at in the process at this point?

You might want to try installing Firefox - it is based on the same rendering engine as Netscape, and importing your old Netscape bookmarks is easy, but doesn’t have as much bloat and IMHO tends to have fewer bugs & problems.

Firefox may not help - I’ve found sites before that check the browser and version, refuse to operate with Mozilla - even though they almost certainly will run OK.

I’m done with the install and everything. I just can’t start the damn thing.

Regarding Firefox: I already run it. My internet bank won’t let me use it there, though, so I need either Explorer or Netscape for that.

Anyhow, I caved and installed Explorer. It didn’t fuck up my system nearly as much as it has done on the previous times I’ve installed it, so that’s good. It does behave a bit strangely, though; if I enter an address manually the computer freezes up, but it can follow links, bookmarks etc perfectly well.