Palm handheld question/help requested

My mother got me a Palm i705 for my birthday. Since she got it reconditioned, I did not get the software on CD (I had to download it), and it doesn’t come with support.

I am having a problem with it. When I try to tap the screen to enter information, I open the icon below or above what I’m trying to do. It doesn’t matter what I’m trying to do; it happens when I’m trying to open an application, tap to enter letters or numbers, or use a drop-down menu. I know I’m hitting the right area, because the icons are bigger than life, and my hand-eye coordination isn’t THAT bad.

So my question is, what’s the deal? Is this a hardware problem, or is it a software thing? This is really getting on my nerves.


When I turned on my palm for the first time, it sent me through several functions so that it “understood” where my stylus was touching the screen. You might be able to reset the palm (using a pen and the hole in the back) or go into the palm’s options/preferences and perform that function again to ensure that the screen is calibrated correctly. As I recall, the function necessitated using the stylus to touch the center of several bullseyes. Once correctly calibrated, your problem should be solved.

I apologize for not being able to get you there all the way. My palm is at home today. Good luck.

This may have changed in newer versions of Palm OS, but my Visor has a built-in program called Welcome which allows you to calibrate the screen by tapping several target points with the stylus. Running it might be a good first step.

Have you tried calibrating it? There is a set-up program that lets you calibrate the stylus and screen.

I’ve done that several times, and I can get through that okay, but it’s still a bit dodgy otherwise.


It’s “welcome” in the menu of my M130 too.

What you’re experiencing is a digitizer calibration error.

If, as you say, recalibrating it using the System/Prefs/Digitizer screen does not fix your problem, you need AutoDigi 2.

If your i705 has Palm OS 5 or above, use AutoDigi for OS 5 instead.

Sometimes it is caused due to a misalignment in the digitizer cable due to rough use or a fall. Reseating the digitizer cable fixes it on some handhelds. Other times it’s a software/OS conflict. It’s popularly known as the “Mad Digitizer” syndrome.

AutoDigi fixes both. It’s an amazing piece of software.

Thanks. Y’all are wonderful. :slight_smile: