Possibility of turning off notifications of Awards?

I have a two-fold question:

  1. Can we selectively turn off which notifications we get? I am flooded with Badge notifications, and it’s cluttering my screen.

  2. How can I “mass dismiss” all of the notifications I’ve already gotten? It’s cluttering my screen and harshing my calm.

Tripler
Mellow. For now.

So your inbox is blowing up?

flees

Not really.

There should be a Dismiss button both on your notification dropdown (click your avatar in the upper right corner) and at Notifications >> All.

You’re getting flood with badges right now just because you’re “new” and suddenly hitting all these milestones. I’ve stopped getting them after a couple days.

There was a button there, but there was no “Notifications >> All.” When I clicked the single, check-marked “Dismiss” button, nothing happened and that “Dismiss” button went away.

Tripler
Let me log out for 10 min, and try it again.

To get to Notifications >> All, click on your avatar, then click on the bell in the dropdown. That takes you to Notifications, and it should default to All.

Exactly how it behaves will depend on your device, your browser, and your theme (skin). If the button went away, the notifications were dismissed. They weren’t removed though. Far as I know, they’re eternal.

I apologize! I misread the earlier post, but have found the “Dismiss All” at Profile > Notifications. Unfortunately, that button is greyed-out, and unclickable. Is it a once-a-period kinda thing?

ETA: Ninja’d! So there’s no way to dismiss and remove them from my ‘top-right Avatar dropdown’?

Tripler
Ready to Dismiss All.

Apparently all the “dismiss” button does is mark them as read.

Is there any way at all to fix that? I seem to have a choice between never having any notifications at all, in any form, about replies to posts I made or threads I posted to, and eventually having thousands and thousands of them all piled up and unremovable. If that’s really a required setting, that’s absurd.

There’s nothing to fix. That’s how it’s supposed to work.

You will have billions and billions of them. But really, how much time do you plan on spending in Notifications >> All?

ETA: However, you can go to Notifications and change the filter to Unread to hide all of your read or dismissed notifications. Forgot about that.

Zilch, apparently, since apparently I can’t even turn them off. I’ve set it to disable them, and I’m still getting them, complete with distracting noise. I suppose if I don’t want to be distracted I’ll have to mute the computer or log out every time I want to do something else; which would be a royal nuisance. Could you at least put in an option to shut up the noise?

But I don’t have to go specifically into Notifications to see the things. Any time I click on the icon for my profile, whatever reason I had for doing that, there they are, taking up space.

And there’s no email notification setting for ‘notify me once a day’; either I turn that off entirely, or they send me an email whenever I haven’t been here for all of ten minutes. Do they expect us to live on the site? – I suspect that they do. I think I’m going to have to turn that off too, and settle for watching threads, or whatever.

Ok, I think we’re talking about two different kinds of notifications. There are Discourse notifications and Live Notifications. Live Notifications give the annoying noise. If you’ve turned them off in Preferences >> Notifications, you may also have to turn them off in your browser.

For the list of Discourse notifications when you click your avatar, that’s just how it’s supposed to work.

– OK, poked around in the browser for a while, found that and turned them off. Maybe that’ll work. But I don’t see why it should have been necessary; if I turned them off here, shouldn’t Discourse just quit sending them?

There’s no way to get email notifications once daily, or to make the other notifications silent (short of muting the computer)?

Hope that helps. And I agree it shouldn’t be necessary.

I don’t know much about the mail system. Once it started crashing the servers at my other D-boards, I turned it off and never looked at it again.

Just got a notification of that post, despite notifications being turned off both in my profile and in the browser.

At least it only showed up as a number next to my avatar icon; the sound does appear to be gone. I surely hope the emails are gone too; will find out eventually.

Yes, that’s a Discourse notification. Those can’t be turned off. Discourse is notifications based.

Ah, yes. Discourse knows better than any of the users how each of us wants to use the boards.

Bah, grumble. I’ll learn to ignore a lot of this stuff, eventually.

Sorry about this, it is temporary, when you start off you get quite a few badge notifications that are there to teach you about the software. Once this initial flood is over in a couple of days, getting a badge notification will be extremely rare.

I saw this was covered but the best you can do is reduce the amount of notifications (watch less stuff / if you must you can as the system to stop notifying you whey you are @mentioned or quoted.

As in you do not want a blue notification for this post that directly quoted you?

Can you explain what specific notification you are trying to get rid of?

All of the old ones.

Hi, @samsaffron, are you a real person? Will you be a regular Doper? Do you know Cecil Adams? Do you really live down under?

Yes, Happy to assist where I can answering Discourse related stuff (within reason) I like a lot of the conversations so I will be lurking here, No, Yes.