Question About Mac OS 10.3.4 Network Icon

I’ve been troubleshooting this for over a week . . . when I click on the Go menu (in Finder) and choose Computer . . . my Network Icon has vanished. I’ve tried Disk First Aid . . . nada. TechTool Pro 4.0.2 usually restores the icon after running a suite of tests/repaires including Volume Structures, File Structure, Finder Info, Directory Maintenance, and Optimization (which takes 3-4 hours). But, it restores the icon for just that session. Shut Down and/or Restart causes the icon to again disappear.

Have any of our Mac users had any experience with this phenomenon, and possibly know of a fix?

System Info:
[li]iMac 17" Flat Panel (Mac OS 10.3.4)[/li][li]GeForce4 MX 64 MB VRAM[/li][li]1 Gig G4 Processor[/li][li]1 Gig SDRAM[/li][/ul]

Thanks in advance for any help/suggestions y’all can give me.

Apparently, you are not the only one:


Not sure what “maintenance on the machine prebinding” even is, or how to repair permissions…

Aha, this discussion might help:


These are all buried a few pages in on some Google searches I did, namely “os x” + network + icon + missing.

Good luck. I’m no Mac guru but I do dig the Google.

I’ve always found apples tech database a great help:

Thank you for the links, Anaptyxis and miamouse.

I’ve just been informed of a workaround . . . not a solution, but it’s doable for now.

If you click on the apple in the upper left hand corner of Finder and choose Force Quit, you can then relaunch Finder . . . this will temporarily restore the Network Icon.

(I should send Steve Jobs a get well card with a little note in it . . . then again, maybe not.)

Are you talking about the Network icon in the shortcut bar on the left side of a Finder window? If so, try this trick:

In any Finder window, type Open-Apple/Up-Arrow until you’re at the root level of the computer. Or Shift-Apple-G (Go->Connect to Folder…) and type in a forward slash ("/").

Here you should see your hard drive(s) and hopefully the Network icon. If you do, drag it back onto the shortcut bar. Incidently this works if you accidently drag CD images, DVD’s, hard drives, etc off of the shortcut bar.

No, it’s not the sidebar icon that I’m talking about.

This is where I don’t see the Network Icon. I see my internal and external hard drive icons (Macintosh HD and FireWire 117 GB), but no network icon. The text is there (Network), but no icon.

If you click on the two links in my OP, you’ll see what I mean.

  1. Open the “Applications” folder.
  2. Open the “Utilities” folder inside it.
  3. Open the “Disk Utility” program.
  4. On the left-hand pane, click your hard disk.
  5. In the right-side pane, click the “First Aid” tab, then click on the “Repair permissions” button.

Personally, I don’t know if repairing permissions will do anything in this case; it sounds like the cached image for the network icon got munged or something. Have you tried just logging out and logging back onto your account to see what happens?

I hadn’t until you suggested it . . . and that also works temporarily. (If you think about it, logging out and then back in is in all practicality the same as relaunching Finder.)

Here’s the scenario:
[li]I start up my Mac . . . click Go in Finder, select Computer and the computer brings up this window.[/li]
[li]I then close the window and relaunch Finder using the Force Quit option. I then repeat step one and the computer brings up this window.[/li]
[li]I then click on the Network Icon . . . the icon changes to this and all is as it should be, until I shut down and/or restart which brings me back to where I started, with no Network Icon.[/li][/ol]
As I said earlier . . . I now have a doable workaround, but this is not a solution to the problem.