Something wrong with search?

I can’t seem to get search to work for me tonight. I wait in between trying, and I’m specifying my terms, and the period, and not getting results.

Search is still not working as it should always when it should.

I’ll repeat what Jerry said earlier, that seems to work most of the time:

Advanced search is working. Tell users to use the Advanced Search option or to go to this URL:

I can’t get Search to work at all. I’ve tried Advanced Search, both at the main url and the one given by TubaDiva above.

When the terms are entered and the Search button is clicked you’re just returned to the Search page.

I’ll bring this to Jerry’s attention, this is a new wrinkle.


Works for me as of now.

This just happened to me, too. And the Advanced Search button doesn’t show up at all under the Search button, as it used to.

Aaaaaaaaand now it’s working again. It is a puzzlement.

It’s a bloody pain in the arse is what it is!


Who’s this mob Whatever search capacities they’re meant to deliver, well they ain’t.

(Edited to add the bit about, just noticed it at the bottom of the screen as the search did it’s fruitless searching, again.)

Now it’s not working again. Just got two “fatal error” messages in a row, ten minutes apart.

Advanced Search works - most of the time. I’ve had a number of occasions when I enter the search, hit the button, and it comes back to the Advance Search screen. Try the same search a half hour later, and it works perfectly.

Well, it would be wrong to say I’m glad others are having this problem, but I am glad it’s not just me! I was beginning to wonder if I was doing something wrong, but I tried several different ways of looking for what I wanted, and nothing worked.

I just now tried the link given above, and got results. There’s only one problem: I know I started a thread to ask about my optical drive; I remember the answers I got. But I can’t find the thread. It’s like it evaporated into thin air! :frowning:

I usually try to remember to bookmark threads I start, or ones that are of particular interest to me, for some reason or other, but I forgot to do it that time (of course; Murphy strikes again!).

This one?

If you click User CP, then on Edit Options, then under “Messaging and Notification” you’ll find “Default Thread Subscription Mode*” and change it from “Do not Subscribe” to one of the other options.
Now, once you’ve done that, all you have to do is click “User CP” at the top of any page it will automatically bring up any threads you’ve started or posted to that have new posts.

*That line is kinda tough to find, you might want to Control-F and search the page for one of those words

Finding the correct replacement optical drive

-Found with advanced seearch.

I’ve noticed that the advanced search page is a little picky about what you do with it.
It’s OK the first time you bring it up, but if your first search fails to bring up the result you want, and you return to the search page using “back” from those results, no subsequent search will succeed. -The search page just sits there after you click the “search” button.

Is it not just the usual x-minute mandatory wait between searches? Except instead of telling you that you have to wait, it just dumps you back at the search screen?

That’s what I’m finding, and it is incredibly frustrating.

Not that I’m pissed-off or anything. :rolleyes:

I usually get the following error message when trying to search for 2 words in an advanced search (even if it’s been days since my last attempt):

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 4194304 bytes) in /home/straightdope/ on line 1008

I really think re-indexing the database would be well worth the effort. Does anyone know if a plan in the works to reduce the 5 minutes required between searches? At least for paying members? Search is really one of the most important features on this board, and right now it is completely crippled. I don’t remember having to wait at all between searches a few years ago.

Thanks, but that’s not the one I had in mind. I created that one after I couldn’t find the one where I asked how do I tell if my optical drive is dead. I got about 3 responses, one saying that, if it’s not reading discs, it’s dead. Another mentioned some kind of cleaning disc I could try, but that it often is ineffective.

I know I didn’t imagine that thread, and SDMB is the only place where I ask tech questions. In GQ, nobody objects to a reasonable amount of thread resurrection, which is what I’d have greatly preferred to do. I’ve found myself starting quite a few threads lately, and I’m beginning to feel strange about it. I’m mostly the self-reliant sort, and I don’t enjoy having to come begging for help. But I’ve simply not had much choice in the matter. I guess it’s like the old maxim about problems being like grapes - they come in bunches. :frowning:

That may be my problem. I hope that’s all it is. And here I thought I was being smart paging back instead of clicking on search again. After all, it’s the logical thing to do when you just want to make a minor modification.

Five minutes? :eek: It didn’t used to be that long.

Mods? Is this the rule now? Tell me it ain’t so, please?

Yeah, the display of search results probably suffers from the same bug that forced Jerry to set the forum view to 200. Something about searching hits the server on the head like a lead brick from a third floor window.

Just wanted to report that the Advanced Search function isn’t working for me (it just refreshes the page).

I had that problem the last week or so but Search is working for me just fine now, both Simple and Advanced