Swapping monitor for flat panel TV in WoW - questions/help/suggestions?

Wasn’t sure whether to put this in GQ or here, so hopefully if I made the wrong choice the mods will move it.

I was running WoW on a 30" Apple Cinema monitor, with 2560 x 1600 resolution. It looked beautiful–very crisp and clean. No real problems with it at all, except that I kind of wanted it to be even bigger.

This weekend I swapped the Apple for a Panasonic 42" flat panel TV (1900 x 1080). My graphics card is an NVidia GTX 460, and my computer is nearly new and pretty powerful (12GB of RAM and plenty of processor power to drive WoW). I also have a second monitor, a 21", off to the side to do things like watch Netflix while I play.

Anyway, I was underwhelmed. The picture seems far less crisp than my Apple monitor, the text is jaggy unless it’s very close, and it just overall doesn’t seem as nice. I checked the settings and noticed that it kicked a bunch of them down to “Fair” (from “Ultra”). I put them back up, but it didn’t seem to help much. Also, on the Video page where it says “Custom,” the bar seems permanently set to “Fair” even after I put everything up to “Ultra” that it will let me (which is most things).

Another problem (this is before I even get in to WoW) is that the picture on the screen is bigger than the screen area. The only way I can fix it is to adjust it in the TV’s settings, which drops the resolution down to 1838 x 1050. Running WoW in full-screen mode gives me the same problem even after the adjustment–things go off the screen a little bit.

Any help/suggestions? Does anyone else run WoW on a screen this size or larger? I really like the crisp clear graphics and would hate to lose them–to the point where if I can’t fix this, I might just go back to the 30" monitor.

One other note: I have the TV on the same table where I had the monitor, but pushed much further back (my computer table is a repurposed dining table, so it’s much deeper than a standard desk). I’d say I’m sitting about 3-3.5 feet from the screen, as opposed to maybe 1.5-2 feet for the Apple. Moving it back even further isn’t really an option (it hits a wall).

Thanks in advance for any advice.

Well you are going to a lower resolution even though the monitor is bigger. Try turning up your Antialiasing settings. If the Panasonic is a Tv go to the settings menu and look at the input you have the PC hooked up to and look for a setting called just scan, 1:1 pixel or some setting to turn overscan off that should clear up your picture being bigger.

The problem seems two fold.

  1. Your TV is over scanning the picture. Make sure your TV display settings are set to 1:1 or pixel. If your still overscanned or maybe even underscanned now, head on over to the Nvidia control panel and correct there.

  2. Welcome to the world of bix pixels. Think about the pixel density of your Apple panel. It was 30 inches and was made up of 4 megapixels. You now have have a screen 12 inches larger on the diagonal but with only HALF the amount of pixels.

The image will not look good close up, and the text may look unclear or too small far away. You might want to try any “high resolution” font settings WoW might have and see if that helps. I second the kicking up AA settings. On a TV it’s specially bad due to the larger pixels. One of the reasons console games looks so bad compared to PC games - little or no AA + big pixels + low rendering resolution = yuck.

I found the adjustment for “Just Scan” and set it, but I’m supposed to be working now so I can’t fire up WoW and test it. I’ll report back when I do.

I realize that the resolution is lower than my monitor, but this TV has the same resolution as our main TV, which is a 60" plasma. I play XBox 360 on that and it looks fantastic. I don’t know how the video card in the XBox compares to the one in my computer, but given that it costs more to buy my card than the whole XBox, I’m going to guess they’re at least comparable. The only difference seems to be that I sit further back when playing on the 60". If that’s the problem then the 42" just might not work out for me since there’s no real way to move it any further back (plus if I move it too far I might as well just keep the 30" and sit closer.)

Is it 1080p or 1080i? Interleaving would explain blurring. You can solve that by v-syncing to 30 fps (which would suck).

Dunno what’s up with WoW not accepting your new settings. Something to try when you get home is to brute force it in the config.wf.

It’s 1080p. Here’s the TV in question.

Are you using HDMI or DVI -> VGA?

I have a DVI > HDMI cable (HDMI into the TV, DVI into the computer).

Do you have a Blu Ray player or PS3?

I do (they’re one and the same) but it’s hooked up to a completely different TV from either the computer or the PS3. Why?

I’m trying to figure out a test to see if your TV is downgrading non-HDCP sources to 1080i, but I don’t know it is yet.

Actually, given that the 460 GTX supports HDCP over its HDMI port, the easy thing to do is yank an HDMI -> HDMI cable from your plasma for a quick test.

Hmm, the GPU that you have is more powerful than what the consoles have several times over. So whatever it is it’s not that.

Is there anyway you can maybe take pics of the monitor and your TV so we cna see exactly what the issue is?

Once the picture is corrected for overscan and you’re displaying a 1:1 pixel image, everything should look good. Mind you, the Apple panel is a way better panel that your TV, but still.

Also are you sure you go the basics covered like having the correct resolution output: 1920x1080?

I can try to take pictures, but all I have to do that with is an iPhone so I doubt it’ll be much help.

Like I said, I already made the 1:1 change but I haven’t tested it yet because I just ran downstairs to do it quickly. I’ll check during my lunch hour. I’m also planning on adjusting the UI scale, which might shrink the text stuff down enough that it won’t look jaggy anymore.

Definitely got the resolution set correctly on both the TV itself and WoW. I’ll probably have to mess with it again to adjust for the 1:1 thing since I had to move the picture around to make it fit before.

Palooka, are you saying that swapping out my DVI to HDMI cable for a straight HDMI at both ends might improve things? I’m not sure my computer has an HDMI slot but I can check.

I don’t have a TV, per se, but I’m running WoW at 1920x1080 on a 26" monitor and I’m not really noticing any issues with the graphical quality. I agree with Kinthalis that you might just not be used to the relatively big pixels on the TV.

Regarding the XBox, keep in mind that much of its stuff is optimized to display nicely at 720p/1080p on a TV-style display. WoW will need more tweaking.

Some TV manufacturers, in an attempt to save money, cheap out on their decoders. Generally, they’ll limit 1080p to the HDCP-capable decoder 'cause Blu Rays are the only source of 1080p video for most people. They use cheaper chips handle the other signals, which are limited to 1080i (or worse.) That’s why a lot of TVs won’t do 1080p over VGA, despite VGA being able to handle that resolution easily. My theory is that you’re running into this problem. Since the 460 GTX supports HDCP over its HDMI output, if you use that (and I’m right), it’ll actually do 1080p and look way better. You see this problem coming up a lot more often with 1080p streams from Netflix and HTPCs that don’t support HDCP.

If you think back, did stationary text (quests, hotkeys, HP/Mana text) look better than combat text or other moving numbers? That’d be another sign of the interleaving causing problem.

Right now, I’m very disappointed with the whole thing, and just about ready to return the TV. The JUST setting (Just Scan) looked worse than ever (things ran off the screen even worse than before) and I couldn’t get anything back to even looking as good as it did last night. I called tech support for the TV and they just confused me even more, telling me that the TV couldn’t actually display 1920 x 1080 on my computer (and pointing me at a page in the manual that seemed to bear this out) even though my video card settings clearly said that the resolution was 1920 x 1080 (native). I just don’t get what’s going on, but it shouldn’t look that bad.

Stationary text looked awful. Quest text, for example was seriously jaggy. Also, I couldn’t even read the nametags on toons that were standing like 10-15 feet away from me. They had to be practically right next to me before their names didn’t look jaggy.

I’ve hooked my 30" Apple back up at this point. The Panasonic was unplayable at lunchtime. Debating whether to call NVidia tech support, but since the card came in the computer, they’ll probably refer me somewhere else.

Hmmm, that is incredibly weird. Did playing with the overscan/underscan settings in the Nvidia control panel do anything?

Are you sure the TV’s zoom is turned off?

Hmm, no, I didn’t do either of those. I’m not even sure I saw overscan/underscan settings in the NVidia panel.

What does the page in your manual say about all of this? Things sound a lot worse than 1080i vs 1080p would cause.

I’m not sure now and I don’t have easy access to it (it’s online but I don’t want to download 30MB worth of PDF). I’ll jot it down when I’m near it and post the relevant stuff.