Verizon vs. WiFi speed

I have a Verizon Fios connection - 25Mbps and solid as a rock. I also have their modem/router they force you to use and for the six months that I’ve had the service, it’s been great - Speed tests on my iPad (which uses WiFi exclusively) also show the same 25Mbps as my desktop (which is hard wired to the router.)

Suddenly, every now and then, my WiFi speeds will tank - down to 1 or 2 Mbps - even though the desktop is still getting the full 25Mbps as always. Naturally, I reboot the router and it doesn’t help. This just started happening a couple of weeks ago.

I run a network watcher which shows what devices are connected to my WiFi and my phone and pad are the only connected devices. I know the watcher is working because I can see my phone come and go if I turn it off and on.

Nothing helps. Then, just as suddenly, maybe a few minutes later, maybe a few hours later, and just as out of the blue, the WiFi will be back to full speed.

So my question is if it is possible for something at the Verizon end of things to cause these fluctuations in WiFi speed? I don’t believe they are deliberately messing with me, but I can’t understand how this is happening or even where the problem might be.

FWIW, a week after this problem cropped up for the first time, I got a letter from Verizon pitching their “new and improved” WiFi router that they want me to buy. I’m not a conspiracy theory guy, but WTF?

Obvious answer would be that someone else is using the same wifi channel or an overlapping one.

On 2.4 GHz (channels 1 - 11 in the US, 1 - 13 in Europe) this is pretty much unavoidable these days. But on 5 GHz (channels > 14) there are more channels, they don’t overlap and the signal doesn’t get as far. Try setting a different channel when this happens.

It’s extremely unlikely that something at the Verizon end would impact wifi speeds and only for a while while wired speed is completely unaffected.

iljitsch pretty well nailed my thoughts about channels being busy. I have a app on my android phone that shows all the wi-fi users in the area and what channel they are on. Find a channel that isn’t busy and switch the router to it.

I have a dual-ban 802.11ac router and I’m the only one on the 5 GHz channels locally so far. My android phone and Roku device are all 802.11ac capable. Great through-put.

In addition to the above, do you have any other wireless devices?

I’m not aware of any tools that show channels are actually busy. You can see how many base stations use the same channel with many tools, but that doesn’t really mean much if there aren’t any users active on those networks.

Not to mention, with the 2.4GHz band, you get interference from microwaves and cordless phones, too.

Thanks for the info - I wasn’t aware that channel traffic from other people’s boxes can affect my speed. Unfortunately, the Verizon “gateway” is a closed system that won’t let me access the router directly to make channel choices.

Odd. My Verizon FiOS service includes a “modem” (router) that I access by going to and entering an account and password, those having been supplied to me by Verizon. I’ve set up port forwarding, modified the name and password of the WiFi, and although the setting under Main/Change Wireless Settings/Channel is currently “Automatic”, I can switch to any specific channel 1-11

model: MI424WR REV I
Admittedly, Verizon’s tech support is extremely variable in quality, and I probably lucked out in getting someone who would actually talk tech to me when I called about port forwarding. But if they told you you have no control over your own network, I’d question that. You should have been issued an acct (usually defaults to “admin”) and password to get to your router’s settings.

If that’s what you really want to do, you can buy almost any other wifi router and plug it into one of the ethernet LAN slots on the back of your Verizon gateway and use that router for your wifi traffic. Then configure the new router any way you want. You don’t even need a full-feature router to set up a new wifi network. Something as simple as this travel router (configure it in AP mode) will do the job.