video card installation

So, I bought a evga e-GeForce FX5200 128 MB PCI video card. My 8 yo son plays Lego Star Wars on our 4yo Dell 2400 with 64MB onboard shared graphics, I thought it would be an easy upgrade. I’m an IT guy but hardware has never been my strong point especially video cards. I was expecting slightly more detailed instructions than I received with the new card, and Dell’s was not much better. So, it’s easy to actually screw in the card, it’s easy to install the drivers, but, at this point, the monitor either has basic 640X480 resolution or the monitor doesn’t work at all, all I see is the mouse pointer.

Point me to more detailed instructions of what to do when? Anyone? The BIOS for the video configuration is “AUTO” or “ONBOARD”. It was AUTO when I checked and I left it that way. The device manage shows that I have the new card installed but I can’t get the PC to actually use it. Or so it seems.

Thanks.

Have you disabled the onboard Graphics in the Device Manager?

I thought of that (eventually), but when do I disable it? I can’t disable the old graphics until I have the new one working right? I can’t disable the onboard graphics if I’m using it, can I?

The new graphics card will work fine in basic VGA mode sans drivers.

  1. Download the new drivers. Run driver installer. (You will probably be prompted to restart. Go ahead. Power down when done.)

  2. Insert new graphics card, and hook the monitor to that output.

  3. Power up

  4. Windows says, “woah! new stuff! whatever shall I do?”

  5. Choose, “install automagically”

  6. Crunches, booms and distant wails are heard. Drivers are installed. (you will probably be prompted to restart. Again. Go for it.)

  7. Choose the screen rez you like from the Display control panel.

I’ll also add: if your screen stubbornly appears blank, and the machine seems bricked, don’t panic. Hook the monitor to the ‘original’ connector, and see if it’s putting out video there. Most likely this won’t happen, and its not that hard, usually, to debug what went wrong. Worst case you buy a new machine. I’m kidding. Worst case you pull the new card, hook it all up the way it was, and Windows burps and looks like it did before.

squeegee, I’m stuck in just what you describe. I had to choose the driver from the CD, it didn’t find it itself when I turned it back on. As it was copying files the screen went blank and it’s in la la land right now.

This happened before, I powered it off and used the old adapter and it was OK. Except I want the new card to be working!

What steps do I take to debug the problem?

OK, brass tacks:

If this is really a PCI card, and there is Mobo (motherboard) video also available, then its likely that both outputs are being recognized, but the Mobo output is the ‘primary’ output, and the GeForce is not, and is not (yet) enabled.

Let’s try to enable the new card, and tell Windows to get with the program:

  • Right click on the desktop, and choose Properties. This will bring up the Display Properties control panel.

  • Click on the Settings tab.

a) Do you see two “monitors” labeled “1” and “2” in the grey area in the middle of that tab? If you do, Windows sees both display cards. So far so good.

b) You do not see two monitors (boxes labeled 1 and 2). This is less good – the drivers are not installed right for the new card. We can come back to this, I think a) is probably the situation you’re in.

  • Click on the box labeled “2”. The controls underneath that area will change, and you’ll see a checkbox labeled “Extend my Windows desktop onto this monitor”. Click on that checkbox so that it is checked. Windows may ask you something like "do you want to keep these settings (yes/no). Choose Yes.

  • Plug the monitor into the New display card. What you should see is the desktop background. If you wave the mouse around enough, you should get the pointer cursor visible.

If this all worked, then you now have Windows thinking you want two monitors, which isn’t quite what you want. This will require some jiu jitsu to fix.

At his point, you can:

a) go into the bios and disable the mobo video, and if you restart, Windows will use the other card as your primary (and only) video device. I’d recommend this path.

b) You will need to swap that darned monitor back and forth a bit:

b1: Hook the monitor back to display #1 (mobo). UNselect “Use this device as my primary monitor” AND “Extend my Windows desktop onto this monitor”. You may experience one of several states where these controls dim. Persevere, Windows is trying to protect you from bricking your machine.

b2: once the geForce PCI card is both the Primary display and the desktop is Extended onto it, the other display output is dead. This is what you want. If you get to this point, just start using the computer and you’re done.

You should be able to disable the on-board video in the BIOS.

What I don’t understand is your statement “the monitor either has basic 640X480 resolution or the monitor doesn’t work at all, all I see is the mouse pointer.”
If you see a mouse pointer, it’s certainly working to some degree. If your onboard isn’t disabled, then my only suggestion is to right-click the desktop and use the Display Manager to set the other monitor to be the primary monitor.

If you can’t disable the on-board and you don’t have a spare monitor, you may have to swap the monitor back and forth a few times.

More possibilities:

You can also end up in an “in between” state, where the new card is recognized, you can get windows to Extend onto the new card, but you can’t get beans for resolution, and you’re stuck at 640x480 x 16 colors. This is OK, it just means the driver installer got stuck. Fix the first problem – make it the primary device – then fix the drivers. Don’t panic, you can back away from the chalupa if things go south, as you’ve already done.

thanks for the help, squeegee. I almost have it, sort of. The new card is working and I think I have the old disabled. Except that the desktop isn’t quite correct. All my icons are gone and the taskbar is gone. So, I didn’t extend it or something? I can’t even get the run window to open. I’m not sure how to turn the thing off!

And I have to go to bed, it’s rather late for EST. Thanks a heap.

It sounds like the other (mobo) video is still active. Check the Display Properties panel and make sure the mobo video seems disabled. All that stuff you’re looking for is probably over there sitting on the other invisible display.

One trick is to use the “arrange icons” menu items available in the right-click-on-desktop menu. This should aggregate all your desktop stuff over on the new monitor.

The task bar (tray) is trickier. If the other monitor is truly disabled, then Windows should shove that over onto the other monitor immediately. You may need to do something stupid like re-enable the old display, drag all your stuff over to the new one, and shut down the mobo display. I’ve never had to do this, and have had my displays in very weird states, but who knows? Make sure you try restarting first, Explorer can get pretty stupid sometimes and a restart gives it the kick in the head you want.

Best of luck.

Almost forgot – the “tray” is independant of the “primary” monitor. You can actually drag the tray wherever you want it, but most people don’t. Right-click on the tray, and make sure “Lock the Taskbar” is unchecked. Then, grab a blank area and you can drag it around the screen, including to the other monitor. This shouldn’t be an issue if you can get the mobo video disabled, but forewarned is four-armed. Or something.

Also: a quick indication of if the other display is still enabled is if you can drag the mouse cursor off the screen either left or right, or if it “sticks” to the edge of the screen. If the latter, then you definitely have one monitor configured; if the former, keep debugging.

OK, one more thing, then you’re on your own, grasshopper:

Your OP doesn’t say where you got the drivers. Do NOT ever ever ever use the drivers that came in the package with the video card. Ever. They don’t flipping work, the mfr puts them there as a practical joke.

Go to either a) the mfr site (if its a reputable outfit), or b) the chipset maker’s site (nVidia) and download the latest drivers. Burn them on a CD or put them in an easily memorable place on your HD. Toss that CD that came with the card back in the box and never look at it again.

squeegee, it’s working fine, thanks for the help. I was using the drivers from the box, then downloaded updated drivers from nVidia. I don’t remember if the version was different or not though. I was confused by the two monitors thing, especially since I don’t have two monitors. But since both graphics units were putting out video, I selected the new one as the default and cleared the “extend desktop” on the old one, then disabled the old in Device Manager and I was done.

Awesome. Glad it worked out! I should have mentioned the “don’t use the stock driver CD” issue in my very first post, apologies.