What's wrong with my new optical mouse?

I bought a Logitech optical mouse (not cordless) and when I first plugged it in it worked just fine. Since it worked as is, I didn’t bother downloading the software that came with it. After turning the computer off and on again, it wouldn’t work (the cursor on the screen wouldn’t move). If I plug the old mouse back in with the computer still on, it won’t work either. If I shut the computer off and plug the old mouse back in, then turn it on, the old mouse works fine. If I then unplug the old mouse and plug in the new one, the new one will work fine again. I just can’t turn the computer on with the new mouse plugged in.

I though maybe this was because I didn’t download the software, so I downloaded it. Didn’t help. Any suggestions (other than calling Logitech, which I’ll do tomorrow if no one here can help me)?

Don’t take offense, but, did you read the instructions?

In some cases, you have to install the software before you attach the hardware. At least, my scanner was this way.

On my last computer, I had a Logitech cordless optical mouse and that’s what I had to do. The software will also have fine tuning features (cursor speed, double click speed. wheel options, etc).

According to the intructions, you are supposed to: turn the computer off, plug the mouse in, turn on the computer, then install the software.

That’s the reason I didn’t install the software at first. When I turned on the computer, it worked fine without the software. Of course after the problem I had, I started over again and installed the software but had the same problem.


More info needed: is it USB? Perhaps it’s in conflict with other USB devices (that’s why I couldn’t use a USB printer on the last computer - it had conflict issues with the mouse and keyboard, I could only use two of the three. I felt like Oliver on Green Acres)

No, its not USB. I don’t remember much about Green Acres, but why did you feel like Oliver?

They had bad wiring (amongst other problems) in their farmhouse. Every appliance had a number. They could only plug combinations of appliances that added up to a certain number (10?). So they couldn’t, say, run the oven AND the TV at the same time.

So is it a serial or PS2 mouse?

Either way, it sounds like an interrupt conflict. I’m a bit hazy on those. Check the box and make sure your system meets the minimum requirements.

I’m sure Q.E.D. will be along shortly.


Its PS/2. Thanks for tryin’ **Mr. Blue Sky[/b[. Time for me to hit the sack. I’ll call Logitech in the a.m. and post back what happened.

Are you sure you don’t have PS2 adapter plugged on to the end of USB mouse? If you do remove the adapter and plug the mouse directly into the USB port.

If you suspect a driver issue simply uninstall the Logitech software, then look for an uninstall any other mouse or trackball software that might be hangin around.

FWIW I’ve always found PS2 only opticals to be somewhat flaky. USB opticals have worked miuch better for me. If it’s a PS2 only optical mouse I’d really suggest returning it and getting a USB version.

Oops. Yeah, it is a PS/2 adaptor on a USB mouse. Its a Logitech MX510.

I didn’t plug it directly into the USB like you suggested yet astro, but I restarted the computer with it still plugged in again and this time it worked. I tried this abot six times before this and it failed every time. Maybe it just took time to get used to? :rolleyes:

I’m going to power down in a bit and we’ll see what happens in the morning. If it doesn’t work again I’ll try plugging it directly in a USB port. Thanks for the advice.

Still won’t work. The reason it worked the one time last night is because for some reason it works when I restart the computer but not when I shut it down completely and turn it on.

I called Logitech and they couldn’t help me. They had me re-boot in safe mode to see what happens and the same problem. After this they basically blew me off.

When I tried astro’s suggestion of taking the adaptor off and plugging it directly in a USB port, it works fine. I’m able to completely shut down and re-start with no problems, however, I’d like to have it plugged in where its supposed to be because Logitech says this is the preferred way and the only USB port I have left is in the front of the computer.

When the unpreferred way is the one that works, I’d say it becomes the preferred way by default!

Add a USB hub, then you’ll have more ports than you can shake a brace of mice at.

My Logitech Cordless Optical Mouse and Keyboard work just fine.

They were installed per directions.

My only complaint is the batteries in the mouse have to be replace every few months. Should have gotten the rechargeable which was a later product. Keeping the mouse on a sheet of white paper extends battery life.

When all else fails read the directions!

Just another shout out for the rechargeable Logitech mouse. I have the MX700 with a keyboard and I LOVE it. I especially love the audio control at the top, the jog wheel for the volume is wonderful. I’ve had it for !5 months and the keyboard batteries are still going strong.

Why would the “preferred way” be to use an adapter that negates the USB mouse’s superior power supply feed, interface speed, and device assignment flexibility under USB. Using the adapter is usually considered the the newbie “kludge” mode for people that don’t know any better or have no USB port. Logitech is saying this (with adapter) is the preferred mode?

Not to question you, but I find that nigh unbelievable esp. for the high performance mouse you have.. Do the instructions say this, or was this from some phone tech?

Yeah, that’s what the tech on the phone told me today. I guess you’re saying the USB port is really the preferred hook-up? If that’s so, I guess I’ll make room at the back of the computer. One of the ports has a cord in it used to update my Treo 600 but I never really do that anyway.

In an earlier post astro, you wrote:

I once had a cordless Microsoft Intellimouse. Do you think some old software or drivers could be giving me a problem? I searched all files and folders for the word “Intellimouse” but nothing came up. Is there something else I should’ve done?

Whenever I have this sort of problem with a device I un-install the mouse and drivers in Device Manager then reboot the computer and have it re-install software to run the device. A lot of times this works fine and is quick and easy. You might try that if you haven’t done so already already.

USB is definitely the preferred way to hook the mouse up, that’s why it’s a USB mouse with a PS2 adapter and not the other way around:)