Why does my keyboard coding not work (Chrome)?

I recently switched to Chrome as my browser. Ever since I have noticed a problem with coding.

Normally, when I want to code for italics, bold or underline, I simply hold down the Ctrl key and hit the appropriate letter (I, B, or U). Since I have started using Chrome, the text acts like I didn’t do anything when I use these keystrokes.

How can I make Chrome behave the way I want it to?

Not sure it’s possible, and if it is, it looks quite complex. Maybe the ‘kiosk’ setting? (They’ve captured all the control values as shortcuts). It may be that for the Chrome people, the preferred solution is for everyone to re-write their message board software to use new CSS tags to identify text input fields? Or maybe they just think that text input doesn’t need non-printable characters.

You can still mouse click on the B/I/U icons, or type the tags by hand (as I do).

This happened to me many years ago with Opera. Upgraded to a new version and suddenly ^B/^I etc. didn’t work here. Had to click on the icons to get the font change.

People started posting about this on the Opera users message board. Opera’s response: crickets.

One of the signs of the downhill slide of Opera. Eventually they even got rid of the message boards.

I suspect Google’s response to this is also going to be crickets.

I don’t understand why browser writers think they don’t have to send all typed characters along. I am typing in a text window. If I type a control character I do not want the browser to grab it and open up the bookmarks pane (for example).

I know this, of course, but being able to skip reaching for the mouse and use keyboard shortcuts instead just seems like something that a Windows-compatible platform should offer.

(I don’t often print from a browser these days, but I suspect Chrome wouldn’t like Ctrl+P either. Grrr.)

Do you mean on the SDMB? The keyboard shortcuts just don’t work in Chrome. They use some old way of making shortcuts that doesn’t work correctly in Chrome.

Only solution I found was to make a userscript. But since no one ever complained about it, I never bothered releasing it to the public. (Also because I added a lot of other shortcuts, and I’m not sure if those are really the best ones: I copied them from MS Word.)

Ctrl-P does work, but that’s because that’s a browser shortcut, not a vBulletin one.

The code isn’t super clean, but here’s the Userscript I mentioned:
https://openuserjs.org/scripts/BigTSDMB/SDMB_Editor_shortcuts

You’ll need to install TamperMonkey from the Chrome store first to install it.

That should work for Opera as well, but, if not, here’s a special Opera version of TamperMonkey.

It should work in Firefox’s TamperMonkey as well.

The “old way of making shortcuts” is that the page/server receives the keystrokes that you type. It “doesn’t work correctly” in Chrome, because Chrome captures and swallows what you are typing. It’s not that there is an “new way” of entering or sending information: it’s that you need to specifically disable the Chrome behavior by some method.

There /may/ be a new CSS tag that Chrome recognizes, that automatically disables the Chrome behavior: that would explain why they think their browser behavior doesn’t matter. Or it may be that they are just focused on phones and tablets, and wish to discourage the use of desktop computers.