Why is Google's main page in a foreign language?

I just opened Google’s main search page and here’s what I found:

WTF?

It happens every time, too. I’ve never visited any site in that language (whatever it is). I’m an English-only kind of guy. I looked at my Google cookies, but the strings therein are impenetrable.

Go to the main page and click the middle link just to the right of the Search text bar (“Preferences” in whatever language you have set currently). The very first dropdown menu is for the language setting. Pull it down and locate the entry for English (it will be the word of English in the currently set language) and click it. Then click the button near the top right of the page, which is Save Preferences (The button text will also read in the current language).

Maltese. Clearly the Knights of Malta have chosen you to deliver the Holy Grail to save the world.

Sure, I know how to fix it. But these settings were all set to “English” already!

Or you can just click that link that says "Google.com in English. After some experimentation, I see it does the same thing as the instructions above, only easier.

Huh. Did you try clearing your cookies?

A blessing! A blessing from the Lord!

Are you connected through a proxy or doing something else that would change your IP address? Google seems to be smart enough to redirect you to their homepage for the country they think you’re visiting from.

If it’s not Google’s own settings, check your browser preferences.

Your browser can be set to ‘prefer’ pages in specific languages, and if the webserver has a page in one of the preferred languages, it will serve that page up instead of the site’s default page. Usually there’s a list of languages, ordered by preference. The browser negotiates with the webserver something like this: “I’ll take French if you have it, if not I’ll take Esperanto, if not I’ll take UK English, if not I’ll take any other form of English, if not I’ll take whatever you have.”

Maybe someone was using your browser in Maltese and forgot to set it back.

No, but as indicated in my OP, I examined them (for whatever that was worth). But how could the cookies have been changed to Maltese, since I’ve never done anything that could even remotely have anything to do with Malta or the Maltese language?

If it was some kind of malware attack (which I tend to doubt with all the anti-virus and anti-malware programs on my system), that’d be a rather silly thing for a virus to do, don’t you think? Of course, there have been intentionally silly viruses…

Nope. Nothing like that at all. Plain, vanilla Internet setup.

Good suggestion. I’m using FireFox and when I looked at the “Languages” settings in the “Advanced” page, it has only two entries: English/United States [en-us] and English [en].

I’m the only user on this, my home machine.

Hmm. Okay. Your Google prefs aren’t set for Maltese, and your browser’s not set for Maltese. I dunno than.

Another thought. Did you inadvertently simply go directly to the web address of a Maltese Google page?

The URL of the main Google page in any language is

http://www.google.com/intl/<language_code>/

where <language_code> specifies the desired language. For Maltese it’s “mt”, so the address of the main Google page in Maltese is

http://www.google.com/intl/mt/

Alternatively, the Google page for Malta itself is

http://www.google.com.mt/ .

Another good suggestion. But I’m afraid that couldn’t happen because I used a pre-set button to go to Google’s main page, and did not type in the URL myself.

Note, by the way, that it’s working fine now.

Okay, my guess, though it’s probably way off.

Every once in the a while someone on the board posts the instructions for doing google in another language (Swedish Chef, Pig Latin, Yiddish, I see Maltese on the list) is it possible you were playing with that and somehow made it your homepage?

Oooh, one more. Is google in your favorites? if you start typing something that’s in your favorites it will come up in the URL bar. For example if I type in my URL bar “the str” it will automatically pop up as “The Stright Dope” and come to this site. It you had google.com/intl/mt in your favorites it might automatically come up when you start to type google. Hmmm, maybe?

I live in Colombia and have never had a problem bringing up Google in English. I do, however ask Google to present searched items in English and Spanish. That seems to work OK. I get more English language searches than Spanish.

It has to be IP address weirdness. Somehow, your Internet connection is getting routed through Malta in such a way that Google thinks you want to be spoken to in Maltese, my precious little falcon. It shouldn’t be possible, but neither should it have been possible to get out of Casablanca.

It could be aliens. Maltese aliens. In which case you may be lucky, because Maltese women can be hot (at least, the one I knew slightly back in Oshawa was).

Sorry, nope.

Nope, I didn’t type anything at all. I merely pressed the Google search button on my browser.

Thanks for your suggestions, however.