Windows System Restore question

Windows has found a new way to exhibit its bloated crappiness- it refuses to restore itself to any of the System Restore Checkpoints in November or October (I didn’t have time to check earlier than that). What would cause this behavior?

Thanks in advance for any light that you can shed on this irritating problem.

Make sure your system time and date are set correctly.

Also, what is the exact message you get when trying to restore?

What does it say in the logs? Do you get any error messages at all? Are you using XP or Vista?


The message says Restore is unable to restore to that date. System date ad time are correct.

That happened to me recently after I installed McAfee. Any date prior to that installation wouldn’t work. Have you installed any programs lately that may have affected restore points?

Go into “Safe Mode” first, then try to do System Restore. This has always worked for me in the past with that exact same error message. Dunno why that happens.

Bingo flex727, you nailed it. Thank you very much.