Annoying Yahoobehaviour

MS Exploder has developed a new habit in the last week or so. After doing a Yahoo search, I’ll click on a link. The link opens up in a new window. If I go to Google, the page opens up in the same window. How do I make it stop opening a new window when I click on a link from a Yahoo search?

I got a pop-up today asking me if I want to learn more about Exploder 8, so apparently the computer updated itself over the weekend; but it was happening last week as well. I have a search box in the upper-right corner of the browser window that is for a Yahoo search. I’d change it to Google (if only to not have to see the ad at the bottom of every Yahoo search), but there’s no Google option in the drop-down menu.

Unfortunately I’m running IE 9 now so I can’t remember if 8 works exactly the same but on 9, you can go into Internet Options and on the General tab there is a Search Settings button where you can change the search provider for the search box.

I wonder how you wound up with Yahoo being the default? Normally it would be Bing.

No idea about the search results opening in a new tab thing.

Yeah, I tried Internet options. It has:

Amazon Search Suggestions – Enabled
Ask.com – Not Available
Bing – Enabled
Google Desktop – Not Available
Yahoo – Default – Not Available

Google is not an option (except for Desktop).

I don’t mind Yahoo. I just don’t like it opening windows.

From your post, it seems that you are using IE 8, which I’m no longer running, so I can’t try to duplicate what you see.

Changing the default search engine:
are you using this method?
http://windows.microsoft.com/en-us/windows-vista/Change-or-choose-a-search-provider-in-Internet-Explorer

Yahoo! search results opening up in a new window:
Are you by any chance logged in to Yahoo! in your browser session? If so, could this be something that is set in the preferences for your Yahoo! account?