Anyone PalmOs gurus present?

I want to try out a program called ‘FreeWrite’ (from I seem to meet all the requirements for the software to run:

I use WinXP home, PalmDesktop 4.1, and PalmOs 3.5.0, and I have plenty of free space on both desktop and pda.

The application installs fine, and runs on my Palm. The program comes with a conduit to get files off your palm. When I look at hotsynch/custom it tells me the conduit is set to ‘do nothing.’ (And it certainly does nothing. Over and over…)

When I click on that conduit and then ‘change’, nothing at all happens. I’d expect to get a menu window so I can change to some more useful setting, but I get nothing. There is file called ‘freewriteConduit.dll’ in my Palm directory.

Fearing that some file had been corrupted, I’ve DLed and reinstalled the current versio of desk top – no change. I DLed a fresh copy of Freewrite. I’ve uninstalled and then reinstalled the thing four times today. No change.

I know the conduit works for other people, but not for me.

Any ideas on why I can’t get the conduit to give me a ‘change’ window?

Does your Windows account have Administrator previleges? IIRC that can be a problem with some Palm software. Sorry, that’s all I can think of.

I meant if you don’t have Administrator privilege, it may cause problems.

Thanks for the thought, but I’m the only account on the computer. I checked to be sure, and it does show me as having adminstrator privileges.

Someone else suggested that Norton Anti-virus interferes with some conduits, but I disabled that and no change.

I think I’m just going to give up on the program. I wanted a simple text editor for my palm that could handle files over 5k and not have a lot of unneeded wordprocessing type commands, but it seems that animal doesn’t exist.

I just tried this on a similar setup to yours. I also cannot get a “change” dialog to pop up, but mine was set by default to “syncronize files”. I created a document called “hi” in freewrite, and in my palm<palmname> folder, a file called FreeWrite-Hi.html was created next hotsync.


LordVor, thank you trying! I actually got a reply from someone at GoKnow software, who said that the conduit doesn’t allow you to reset its hotsync status in the usual way. Instead – well, I tried his solution, and have written back to him about the result, so to save time I’ll just paste my reply here:


First, thank you for replying to my post.

I m sorry you re having problems with the FreeWrite conduit. I think I know what the problem is. You probably had an old version of FreeWrite on your computer. When you downloaded the new version, you had the old conduit setting at do nothing . This then becomes the new conduit setting, by default. I can t really say why.

This is quite possibly true – when I first got my Palm I downloaded and tried a lot of programs. I don’t know why I would have set the conduit to ‘do nothing’ but it’s not impossible.

The company that developed our conduit didn t do it the standard way. Therefore, you can t customize the conduit (change it from do nothing to sync).

Perhaps you could suggest, whenever it might be time to update the program, that it would be nice if they let people change the settings that way? Surely others are running into the same dead end.

When you delete the program, are you using Add or Remove Programs from the Control Panel? In the list there, do you have Hi-CE FreeWrite? Because if you delete that old version, delete the new one, and install again, that may fix it.

I looked in Add/Remove, and there was no listing for H-CE, or for GoKnow by that point – I’d already uninstalled all my attempts from yesterday.

Or& you may have to delete it from the registry.

Then I ran RegEdit, and I found a folder for “Hi-Ce” under software, under which was a folder for “FreeWrite”, and it had two keys in it. I deleted that folder. I searched on ‘freewrite’, and nothing else came up in RegEdit.

To be sure I had gotten rid of any left over files I search the entire disk for all occurences of “freewrite” and “Hi-CE” and “goknow”, and deleted everything except the latest self-installing file I DLed yesterday.

I also deleted FreeWrite from my palm.

Then I rebooted and checked the Palm Desktop – it no longer listed a FreeWrite conduit.

Then I reinstalled from yesterday’s download, and hotsynched my palm. I opened Freewrite on the palm, created a test file, and did another hotsync. Then I used the ‘View my handheld files’ from the Start Menu. When I clicked on ‘FreeWrite’, it said “no projects.” I checked in the Palm Desktop: the FreeWrite conduit is listed, but it’s set to ‘do nothing’ again.

This is soooooo frustrating!

I ve passed the question on to a more knowledgeable computer person (a programmer) to get his say. Try the uninstall method first, and we ll see if we need to go with the registry.
I hope your programmer has some suggestions to try. The only further idea I had was to try to get the already-installed conduit file from someone who has it working, and copy it into my c:/palm directory manually. I have no idea if this has even the faintest chance of working.

Again, I m sorry it s not working right, and hopefully you ll be up and syncing very soon!
So do I. I’ve been looking for a text editor that can handle files over 4K WITHOUT a whole lot of formatting overhead, such as with WriteSmith – but there just don’t seem to be any.

Once again, I thank you for your courtesy and attempt to help me.