Can't open new window in IE6

My problem is pretty much what the title says. I can browse normally, but if i try to use the context menu to open a link in a new window, or if the link itself is written to open in a new window, it won’t work. The window tries to open, but just stays blank and shows no activity.

I’ve got Spywareblaster running constantly, and i ran a virus check, as well as Spybot and Adaware, and found nothing.

I found this article in the Microsoft knowledge base. I tried the part of the resolution that involved typing the different dll files, along with regsvr32, into the “Run” box, but it didn’t solve the problem.

The next step suggested by Microsoft is to look and see whether three particular registry values (all starting with HKLM) are present and correct. Of course, MS assumes that i know how to do this, which i don’t. If anyone can help me, that would be great.

Also, if this doesn’t work, it say that the next step is to reinstall IE or, if your version of IE that came with Windows, to reinstall Windows. I have a Dell computer with a Reinstallation CD. Is it possible for me to reinstall Windows without losing all my files and programs, or will the process erase the HDD completely?

Any advice most appreciated.

Note: this is not especially urgent, as i do all my own browsing in Firefox. I do, however, write some web pages which i need to test in IE before posting, so having IE working properly again would be nice.

When IE decides to go haywire on me, here’s what I usually do.

  1. Delete all IE cache files. Tools->Internet Options->General->Delete Files. This process can take a long time, of course it depends on your cache size, but it usually takes about 15 minutes on my PC.


Good luck.

You can get into the registry bu going to start > run, then type in regedit, hit enter or the ok button

In IE 6 you can clean the temp internet files easily by going to tools > internet options, then click the delete files button, check delete all offline content then click ok. this usually takes several minuntes to run. After it runs be certain to close all browser windows and then reopen one to test it.

if nothing else works you can uninstall IE back to the previous version. This will fix this problem, it just puts you at IE 5.5
go to start > settings> control panel> add/ remove programs
then find IE and click change or remove
it should give you a choice to restore previous version, or something like that.

I’ve done phone support for ISPs and for Microsoft; for IE issues, always clean up IE first.
Click “Delete Cookies”, “Delete Files”, and “Clear History” on the General tab…
Verify that the Security and Privacy settings are on default
On the Content tab hit “Clear SSL State” if it’s there
On the Programs tab click “Reset Web Settings”
On the Advanced tab click “Restore Defaults”, then uncheck “Enable 3rd party browser extensions”.

This last will disable most browser add-ons. People with XP + Service Pack 2 will have an extra option (I forget where it is, I’m running 98 on this machine right now), to edit which browser Add-Ons they’re using, and can disable specific suspicious ones.

You can see what ActiveX controls have been added to IE in the General tab by selecting Settings, then “View Objects”. Anything in that window can be deleted. If you visit a site that needs it, it’ll get installed again.

I also recommend using the PestPatrol scanner. They charge $$$ for actual removal, but their scanner is free, fast, and seemingly more sensitive that both AdAware and Spybot.

Try this patch…

Thanks for the advice. Next time, you might like to actually read the OP:

My IE has a mind of it’s own. Sometimes when I open a new window the font size is set to “large”, other times it is set to “medium”. Then sometimes it just stops making large font windows and will always make medium font windows, that is, until it wants to make large font windows again at random.

IE has a similar tic with new window sizing.

:: shrug ::

Thanks for the replies folks, but as the MS article i linked to suggests, a simple clearing of the cache etc. isn’t going to fix this problem. I tried all that before i posted the question.

I think my next step is to uninstall and reinstall IE, but i don’t think i can do that without reinstalling Windows also, which is a pain in the ass.

Before re-installing, read up on the Internet Explorer Repair Tool if you have it with your version. I don’t know if it’ll help you, but it might be worth a shot.

Whoops! I had this all typed up yesterday, but never hit submit. One downside to tabbed browsing. :smack:

You’re right, you can’t uninstall IE. (Uninstalling the “IE” in Windows Components actually only removes the links to it, not the code itself.).

Here are some other things to try:

  • Does the same behaviour affect all users? Create another user account and see. If it works, migrate your files over with the File Migration Utility, or whatever it’s called.

  • Run ie6setup from here. This’ll re-install most IE files from the Service Pack 1 for IE6 setup. If it says you already have a newer version installed, look here.

  • Run “sfc /purgecache” and “sfc /scannow” with your CD in the drive. This’ll run the System File Checker, which’ll replace any system file it finds a problem with with either the version found in your Service Pack directory, or from the CD. (If it says it needs the CD, hit “Retry” a bunch of times).

  • Using your retail Windows CD, or the Dell CD (Dell’s OS CDs function much like the standard Microsoft ones do. I wouldn’t try this with a Toshiba… definately not with a Sony), boot the PC with the disk in the drive. Follow the directions listed here to perform a ‘repair install’ of XP. (It’s called an “in-place upgrade” on that page, whatever).
    NOTE - You’ll lose all your Windows Updates if you do this one. Read the disclaimers against data loss - I don’t work for MS anymore, so I don’t have to. :stuck_out_tongue:

Thanks for the advice. I’ll try the reinstall option.

Just one question about the REgistry Settings instructions from here:

It says to go to the software registry area and “Change the value data from 1 to 0, and then click OK.”

I assume that this means to change the number under the “IsInstalled” category? In that area, the number is currently 0x00000001 (1)

What do i change? The first 1 after all the zeros? Or the 1 in the brackets? Or both?

I don’t have much experience messing around in the registry.

That’s only for if the program doesn’t install, but yep, that’s what you’d change.

That’s just the way regedit displays numbers. If you right click on it and choose modify, the actual entry under “Value Data” will be “1”. Just change this to 0 and hit ok. Don’t worry about the “Hex/Decimal” selection. 1 and 0 are the same in both.

OK, now i’m really fucking confused.

I tried to update IE6, but it wouldn’t do it because it told me that i had a newer version already installed. Fair enough.

So i went into the registry and made the appropriate change, as suggested by the MS article. Then, i tried again to install IE6.

The program started downloading a 7.5meg file from the internet, althugh it jumped straight to 3.6meg at first (presumably because some files are already on my coimputer), and then download the final 4meg at regualt speed.

Then it started the installation process, and it looked like everything wa going well. But about 2% into the installation process, i get a message that says:

“The software your are installing has not passed Windows Logo testing to verify its compatability with Windows XP. This software will not be installed.”


IE6 comes with XP as part of its standard installation. How the fuck can it not have passed Windows Goddamn Logo Testing?

Man. Well, there are 2 reasons I can think of that this might happen.

  1. A conflict with an installed patch (See MS article here.

  2. There’s a problem with cryptographic services. I forget where the MS article is, but this page has what to do.

I think there are some .dll files you may want to re-register if that doesn’t work; I’ll see if I can find them later.

Ah, I’ve found it - article 822798. Steps for generic problems with the cryptographic service. (I usually skip method 1 in favour of doing #3 already, that’s up to you).

If you don’t put your coffee mug through your monitor after doing that, feel free to post s’more error messages. :wink:

Note also that (with retail XP at least, usually with OEM installs too), you get 2 free support calls to Microsoft. I never knew that before, but it’s always struck me as one of the more decent things MS has going for it.

Thaks for your help, Nanoda, although i’m still stumped.

I went to article 822798 and started working my way through the possible fixes, trying to reinstall IE after each fix.

Fisrt i tried the “Rename Edb.log file” fix, but i still got the “Windows Logo” incompatability error. Then i tried fix 2, “Set Cryptographic services to Automatic,” with the same result.

It got interesting when i went to fix 3, which told me to go to the command prompt and type each of the following lines, hitting “enter” after each line:

I typed the first line and hit “enter,” and the computer said that Cryptographic Service was succesfully stopped.

Then, i typed the second line and hit “enter,” but the only message i got was “Access denied.” I tried it again, with the same result.

Looks like this might be some sort of problem i need to fix.

Anyway, i went on and tried the other fixes but they didn’t work, so then i went to the page about the conflict with an installed patch, and tried that fix, but it didn’t work either.

I’m puzzled and rather annoyed, and it’s getting to the stage where i migfht just say “fuck it” and try to reinstall Windows, although i’d definitely prefer if i could do that without wiping my hard-drive completely.

Yeah, I know that feeling. :wink:

You can still do a quasi-reinstall (a repair install) of WinXP as in the last item of my post #10 here.

What that step 3 is about is renaming one of the directories the catalogue program uses, which should force it to recreate it using valid default data. (In case anything in there is right now is wacky). Not sure why you would get an error message here… the other steps require you to be an administrative user on the system, so that’s probably not the problem.

If you want to re-try that step, you can try starting your PC in safe mode and re-running those commands.

Thanks. I might just go for the repair install option. Before i do that, though, i want to back up my important work, just in case.

I agree that it wasn’t just an administrative user problem. I have three accounts on the computer, two limited and one administrative user, and i did all the steps in the admin user account.

Thanks for your help. I’ll try the repair install in the next couple of days and let you know how it goes.