Internet Explorer 6 won't open links in new windows

I have avoided posting this question here as long as I could, but the other resources I have tried have failed me. So, in spite of thinking mundane computer questions boring, I am asking one myself.

Internet Explorer 6 has developed a wierd quirk. Whenever a link is programmed to open in a new window, it craps out.

It’s actually kind of wierd, the way it happens, too. The new window opens on top of the old one. The navigation bar is there, but rather than displaying the new page, the new page is transparent. You can still see the old page through it. However, you can’t click on any of the links on the new page, because it is not active, it is just visible through the active page. Consequently, it looks like the computer has frozen up, but it isn’t. If you click on the to close the window, the new window is out of the way, and the old window works fine. (Except, of course for the fact that the links that open in new windows don’t work any better than before.)

In some cases I can cut and paste the link into the address box to view the new page, but not consistently.

This has made some sites virtually unusable, including the Microsoft Help Message Board (doesn’t that figure?) and some game sites that open the game in a new window.

A suggestion to reinstall three .dll files did not correct the problem.

Who can help?

Start>Run>“regsrv32 urlmon.dll”

This is a common problem, and that solution tends to fix it.

Also, you were silly to even try to get help from Microsoft. That’s like going to the guy who shot you for medical attention.

Is it your anti-pop-up-ad software? That’s fairly common. Just a guess, though.

Thanks, but that is similar to the fix I tried, which is…

…followed by a restart.

This does nothing to resolve the problem.

Is there a sequence I should follow. I have tried restarting between each, and after all 3 have been performed.


P.S. I have no pop-up-stopper programs installed.

look at:

I had the same problem. Open a command prompt, and run the following commands. For me, only registering them all worked. Just registering the 3 you tried didn’t help me, either. I’m not sure which one was causing the problem.

regsvr32 Shdocvw.dll
regsvr32 Shell32.dll
regsvr32 Oleaut32.dll
regsvr32 Actxprxy.dll
regsvr32 Mshtml.dll
regsvr32 Urlmon.dll

Go here for more ideas.