Has the SDMB's web address changed?

My bookmark to the SDMB no longer seems to work. It just conked out. Little back-and-forth balls (latest Firefox, Windows 10) forever. Not even a 404, just … nothing. My bookmark’s address is:


Now, when I can get in, the address seems to be


Has something changed? I’m able to get in now by going to the Straight Dope home page and clicking “Message Boards,” but that’s a bit of a clumsy workaround. Should I bookmark the “new” address, or will the “old” one work again at some point?

This link works for me on Windows 10, Firefox 116.0.3.

What happens if you type the address directly into the address bar on your browser?

Do you have any addons that might prevent the page from loading? Do you have an ad blocker, and if so did you maybe accidentally block one of the page’s elements?

That link works for me … eventually.

I don’t seem to be able to get here from Google, which is my default home page. All I get is “read.google.something,” where “something” is a word I cannot remember.

I tried going straight from any old site (I used CNN), and I did get here, but again, eventually.

I do have AdblockPlus, and ads are blocked on this page, as they always have been. No elements seem to be blocked.

If I have to keep a tab open to the SDMB, then I will; but again, that’s a workaround. It would be nice if I could just use the bookmark. At least, I was able to get here … eventually.

That _ga bit refers to google analytics. Has someone (admin) being
changing anything ?

I have no admin; this is my own personal computer.

Oh wait—weird things have been happening. I can no longer access Google Maps (more on that below). I get a “See your Admin for permissions” or similar message. Thing is, I have no “admin”. Mine is a privately-owned computer, not part of any workplace network or anything.

I did find out that I can access Google Maps if I open a private window. So I can do that, but again, it’s a bit of a clumsy workaround. Even if somebody posts a Google Street View photo here on the SDMB, I have to right-click and select Open in Private Window.

ETA: I should add, thanks for that bit about Google Analytics. I have no idea what that is, but on multiple occasions this past week, I’ve had an annoying Google popup when I’ve visited just plain Google telling me to sign into Google. Something to do about passwords, which is a request that I am understandably reluctant to oblige. I’ve just refreshed, and the popup goes away, until the next time I visit the Google search page, at which point it reappears.

I don’t know if this helps, but if it does, there you go.

If things work in a private window in Firefox but not in a regular window, you can try clearing the cache by following these instructions.

The key difference between private browsing mode and regular mode is the creation and use of cached data and cookies. Browser caches can sometimes cause problems. As you can see from the tutorial, you also have the option of clearing all cookies but that should only be done as an absolutely last resort because a lot of site-specific saved preferences and login information and the like will be lost. Clearing the cache, however, is harmless and actually frees up disk space.

I was having the same problem earlier. The site would eventually load after about three minutes of nothing, but every time I opened a thread in a new tab, the whole process would start over, so I just figured it was a weird server or DNS error and gave up for a while. It’s working fine for me now.

I’ve had problems for months now. Have to keep trying to access from my “favorites” list repeatedly. Sometimes 10 or 15 times. Had to do it over 30 times this morning and got the message to slow down as I was making too many attempts.

That sounds like typical Discourse, to me.

Get Google and all their ad-mongering out of the way and your troubles will be over.

Another user is having issues which seem to be caused by Firefox …

Seems fine this morning, finally.

I got a related problem recently when going to the Straight Dope main page (as opposed to the SDMB main page)

https://straightdope.com/ does not work (but seems to have worked at some time in the past because my phone autocompletes the URL straightd to that. Also according to archive.org that URL seems to have worked as recently as 16 August 2023)

https://www.straightdope.com/ works.

Seems fine today for me too. Weird, but I’m not going to complain. Whoever did whatever–thank you!

I found I could no longer access the site on Firefox this week. But I then installed Chrome and it worked fine, and I’m using that now just for the boards.

But I’m also using a computer so old it burns coal, so there’s that.

I already brought that up in a recent thread.

In poker they say, “if you look around the table and can’t spot the sucker then it’s you.”

Similarly, If you look around your computer and can’t spot the administrator then it’s you. :smile: