Help! Firefox went all kooky on me.

So I tried to open Firefox and it gave me this user selection screen with a user named default. I tried to click that one, but it told me that it was already in use and I had to try another. I didn’t have another so I created a new ‘default user.’

Well, now I seem to have lost all my passwords, extensions, themes, etc. Does anyone know how I can get back to the original user?

Have you tried completely exiting out of all your Firefox windows and then restarting it? It will presumably start back up with the old default profile, which will have your bookmarks, et cetera.

Yeah, tried rebooting as well. I think I remember a “don’t ask me this again” box which was checked by default. Logic would dictate that there’s some way to get back to that prompt, though.

You should find the Profile Manager in the Mozilla Firefox folder in your Start menu. It might be worth it to check if you can switch to your old profile there.

You probably got that prompt because you tried to start a new Firefox browser when one was already running. You can try doing that on purpose, and see if your old default profile is there.

The same thing happened to me once.

I gave the three-fingered salute (CTRL-ALT-DEL), and then, in the Processes tab, shut down all running instances of firefox.exe one by one. Closed the box, and restarted Firefox, and everything was A-OK.

Note: i’m not sure if this was a smart thing to do or not, but it seemed to work with no adverse consequences.

Like everyone says, Firefox thinks you’re already running a firefox process someplace. Assuming you’re using an MS OS, hit Ctrl-Alt-Del and kill all running processes, or just reboot.

Using NS 4.7x on a *nix box back in university, it would sometimes crash and perform likewise, 'cause it hadn’t removed a file that was acting as a semaphore. If you reboot and this still happens, there’s probably a file or registry key you can change. (Though what it would be I have no idea).


Restarting and rebooting didn’t work. My mistake was most certainly creating a new user profile rather than just starting things over right then and there. I had .9.1 anyway, so I went ahead and upgraded. Installing the new extensions was only a matter of a few minutes, but retraining Adblock will be a bit annoying.

Here .
A bit late I know, but it’ll probbaly still come in handy some day.

'course you did say you rebooted earlier. :smack:

Have you tried running the Firefox Profile Manager? I’ve got an icon for it in my Firefox program group. If not, it appears to be launched by running “firefox.exe -ProfileManager”. I’m sure someone else has had and solved this problem, but I haven’t found anything just yet.

I do remember having this profiles problem once with an earlier version of Firefox (maybe a .8.x) when I tried to install more than one extension without restarting Firefox between each one.