What's going on with the page header

The title header with the login button and menu controls is wider than my screen. The list if forums and threads is all scrunched down as really tiny text with a big open space on the right.
This is on a samsung s10e, android v10, brave browser 1.17.72

I went to brave’s suppprt forum to see if this was a common thing and didn’t find anything. Brave, it seems, also uses discourse for their support and bug reports from users and on their forum I didn’t have the same issue.

I am seeing “THE STRAIGHT DOPE MESSAGE BOARD” with distractingly ugly image artifacts of the crappy JPEG type, like it was not properly rasterized at the correct resolution.

ETA @DorkVader also using the mobile theme?

Straightdope light.
I didn’t think to check other themes but now that I did it’s the same in all of them.
Doesn’t seem to be a problem inside threads just every where else. Do you have to side scroll to get to the control buttons also?

I tried it on Android Firefox and it looks OK in both mobile and normal… perhaps check on the same device but using a different browser?

All spitballin’ here …

IMO something in your copy of the theme or the browser is corrupted.

If you haven’t, try clearing the cache (if brave offers that option), force-close the app, & reboot the phone.

logging out before cycling those things above and logging in after you’ve done so is another ploy worth trying.

I’d also want to check the zoom level of the browser . If you pinch or spread the screen how does that react? If there is a explicit browser or phone-level setting for zoom, reset it to 100%.

Cleared the cache, as far as zoom, in or out the proportions of screen and header to forums (it’s now just the forums page) remains the same. I even tried switching from mobile to desktop version and all that changes was the buttons were rearranged in the header.

I’m down to just shrugging now. It doesn’t really seem to affect anything of importance, it’s just visually irritating

I noticed the same thing on my phone earlier, but it seems to be back to normal now. I wondered if it was because the banner ad at the top of the page was a fixed size and messing up the layout.

I did not think of that. Maybe it is the ads messing stuff up.

I just had it happen again and the ad hadn’t even loaded, just had a blank space with the word ‘Advertisement’. But perhaps the browser allocates the space before loading it.

It’s settled then, the ads are malfunctioning cause now I’m seeing blank “advertisement” or one of those broken link gizmo thingies also

I mentioned this over I. The thread about ads and members still getting them.

My workaround is to use adblock on the blank space and word ADVERTISEMENT. I just used my asblock’s “element picker.”

Can you get adblock for mobile? None of the apps have good reviews.

I use Firefox for Android and the uBlock Origin “extension”, but I’m hesitant to recommend it anymore due to some recent changes, likely due to having to fire so many developers.

I’ve read that Edge has Adblock Plus included now. I might recommend trying that. It’s just basically Chrome with Microsoft’s branding, but they decided to include an option to block ads. I’m not sure, however, if it gives you the ability to disable ABP’s “unobtrusive ads” option. But it might, seeing as Microsoft (unlike Google) is not an advertising company.

A website that I trust recommends the Kiwi Browser, which is based on Chrome but has adblock built in. I’d probably try Edge first, but if it doesn’t adblock enough for you, try this one, as well.

Unfortunately, I’ve only tested Firefox. It’s okay, but the newest version “Daylight” replaced an older version that just worked with one that has a lot of bugs, especially on Discourse websites. And they stupidly blocked your ability to try and tw except as a possible last choice.

Those are adblock for browsers. If you want adblock for your entire phone, that’s a different story, and I’ll have to go back and check which ones I found worked best on un-rooted phones. (If your phone is rooted, the answer is easy–AdAway.)

And for YouTube, YouTube Vanced is excellent. You’ll have to install it from its website, however.

Kiwi browser huh? Yeah, I’ve seen that the last few times I’ve looked at browsers. Thanks for the trust tip, @BigT, I’ll give it a closer look.

Is the youtube vanced something that works with the youtube app or with a browser? Both maybe? Eh, I’ll just go look for myself.

Ok, well, trying out edge, (i did not realize microsoft had moblised [as opposed to mobilized]their browser)

I installed and looked at kiwi, aaand a couple others and there were a few things (related to location snooping) that they were pretty blatant about that I didn’t like.

So far the header is still messed up but not nearly as bad

Note that installing Edge is not enough: you would need to enable adblock and then do what I said above about blocking those additional elements.

As for location, I do see it saying it will enable location info being sent tothe search engine (suggesting Chrome does this as well!) However, you can always turn off location for the entire app, which is the default on my device.

I also note that Bing has fingerprint tracking, and would suggest those who are privacy conscious not use that search engine outside of Incognito mode.

Working for me now.